summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-21 08:23:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-21 08:23:16 +0000
commit1f475c9cba73a1dbf16387b61acb60e4870bd863 (patch)
treeb505a555e75e43ea30aa5118493e4f8d9881a9af /games-arcade
parentFixed a problem with dspam where the agent listed in quotes seemed to be mang... (diff)
downloadgentoo-2-1f475c9cba73a1dbf16387b61acb60e4870bd863.tar.gz
gentoo-2-1f475c9cba73a1dbf16387b61acb60e4870bd863.tar.bz2
gentoo-2-1f475c9cba73a1dbf16387b61acb60e4870bd863.zip
Initial commit - ebuild supplied by rohan@mizzenblog.com via bug #57558
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/spout/ChangeLog10
-rw-r--r--games-arcade/spout/Manifest2
-rw-r--r--games-arcade/spout/files/digest-spout-1.21
-rw-r--r--games-arcade/spout/metadata.xml5
-rw-r--r--games-arcade/spout/spout-1.2.ebuild44
5 files changed, 62 insertions, 0 deletions
diff --git a/games-arcade/spout/ChangeLog b/games-arcade/spout/ChangeLog
new file mode 100644
index 000000000000..c354e2ff0392
--- /dev/null
+++ b/games-arcade/spout/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/spout
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spout/ChangeLog,v 1.1 2004/07/21 08:23:16 mr_bones_ Exp $
+
+*spout-1.2 (21 Jul 2004)
+
+ 21 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +spout-1.2.ebuild:
+ Initial commit - ebuild supplied by rohan@mizzenblog.com via bug #57558
+
diff --git a/games-arcade/spout/Manifest b/games-arcade/spout/Manifest
new file mode 100644
index 000000000000..c69750c58f77
--- /dev/null
+++ b/games-arcade/spout/Manifest
@@ -0,0 +1,2 @@
+MD5 0a333e1f55594878e7fcf4f33bc25e60 spout-1.2.ebuild 855
+MD5 a3c4db96d537df28af9df7322a420a29 files/digest-spout-1.2 66
diff --git a/games-arcade/spout/files/digest-spout-1.2 b/games-arcade/spout/files/digest-spout-1.2
new file mode 100644
index 000000000000..e96bdb944d93
--- /dev/null
+++ b/games-arcade/spout/files/digest-spout-1.2
@@ -0,0 +1 @@
+MD5 952ac74f75b93d3b4fbd9ce9cde0e6d0 spout-unix-1.2.tar.bz2 84679
diff --git a/games-arcade/spout/metadata.xml b/games-arcade/spout/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/spout/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/spout/spout-1.2.ebuild b/games-arcade/spout/spout-1.2.ebuild
new file mode 100644
index 000000000000..de8ab24e0784
--- /dev/null
+++ b/games-arcade/spout/spout-1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spout/spout-1.2.ebuild,v 1.1 2004/07/21 08:23:16 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://code.mizzenblog.com/index.php?cat=2"
+SRC_URI="http://code.mizzenblog.com/spout/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ >=media-libs/libsdl-1.2.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dogamesbin spout || die "dogamesbin failed"
+ insinto /usr/share/pixmaps
+ doins spout.png
+ make_desktop_entry spout "Spout" spout.png
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "To play in fullscreen mode, do 'spout f'."
+ einfo "To play in a greater resolution, do 'spout x', where"
+ einfo "x is an integer; the larger x is, the higher the resolution."
+ echo
+ einto "To play:"
+ einfo "Accelerate - spacebar, enter, z, x"
+ einfo "Pause - escape"
+ einfo "Exit - shift+escape"
+ einfo "Rotate - left or right"
+ echo
+}