summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-01-30 16:06:43 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-01-30 16:06:43 +0000
commit72d108341b52a532d899726f0431dbb3c27e706e (patch)
tree01f20327dc56fad6c7dec95dcc75e84045510773 /games-arcade
parent Sync to stable branch, fixing bug #256389. Desktop entry fixes. (diff)
downloadgentoo-2-72d108341b52a532d899726f0431dbb3c27e706e.tar.gz
gentoo-2-72d108341b52a532d899726f0431dbb3c27e706e.tar.bz2
gentoo-2-72d108341b52a532d899726f0431dbb3c27e706e.zip
Fix --as-needed bug #247295
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/aop/ChangeLog8
-rw-r--r--games-arcade/aop/aop-0.6.ebuild14
-rw-r--r--games-arcade/aop/files/aop-0.6-as-needed.patch9
3 files changed, 22 insertions, 9 deletions
diff --git a/games-arcade/aop/ChangeLog b/games-arcade/aop/ChangeLog
index 77d7b3e95ca1..1d55d7aaa4b6 100644
--- a/games-arcade/aop/ChangeLog
+++ b/games-arcade/aop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/aop
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/ChangeLog,v 1.9 2007/04/09 21:44:16 welp Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/ChangeLog,v 1.10 2009/01/30 16:06:42 tupone Exp $
+
+ 30 Jan 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/aop-0.6-as-needed.patch, aop-0.6.ebuild:
+ Fix --as-needed bug #247295 by flameeyes@gentoo.org
09 Apr 2007; Peter Weller <welp@gentoo.org> aop-0.6.ebuild:
Keyworded ~x86-fbsd wrt bug 173405
diff --git a/games-arcade/aop/aop-0.6.ebuild b/games-arcade/aop/aop-0.6.ebuild
index a7fa91eca331..fb8afe5034e3 100644
--- a/games-arcade/aop/aop-0.6.ebuild
+++ b/games-arcade/aop/aop-0.6.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/aop-0.6.ebuild,v 1.11 2008/07/22 16:14:12 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/aop/aop-0.6.ebuild,v 1.12 2009/01/30 16:06:42 tupone Exp $
-inherit games
+EAPI=2
+inherit eutils games
DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code."
HOMEPAGE="http://aop.raffi.at/"
SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
-LICENSE="GPL-1"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 ~sparc x86 ~x86-fbsd"
IUSE=""
DEPEND="sys-libs/ncurses"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e "s#/usr/local/share#${GAMES_DATADIR}#" \
aop.c \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
}
src_install() {
diff --git a/games-arcade/aop/files/aop-0.6-as-needed.patch b/games-arcade/aop/files/aop-0.6-as-needed.patch
new file mode 100644
index 000000000000..59206bca10f1
--- /dev/null
+++ b/games-arcade/aop/files/aop-0.6-as-needed.patch
@@ -0,0 +1,9 @@
+--- Makefile.old 2009-01-30 17:00:58.000000000 +0100
++++ Makefile 2009-01-30 17:01:15.000000000 +0100
+@@ -1,5 +1,5 @@
+
+-LDFLAGS = -lncurses
++LDLIBS = -lncurses
+
+ aop: aop.c
+