summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-06-21 13:20:47 +0000
committerHanno Böck <hanno@gentoo.org>2008-06-21 13:20:47 +0000
commit801d86857021f0e4a7c50da84d6b3d1a2df2fc85 (patch)
treea16646e206ddb4c556fd8a1b39d6b278f6e81796 /games-arcade
parentStable on ppc wrt bug 227603 (diff)
downloadgentoo-2-801d86857021f0e4a7c50da84d6b3d1a2df2fc85.tar.gz
gentoo-2-801d86857021f0e4a7c50da84d6b3d1a2df2fc85.tar.bz2
gentoo-2-801d86857021f0e4a7c50da84d6b3d1a2df2fc85.zip
stepmania fix for new ffmpeg
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.4 i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/stepmania/ChangeLog6
-rw-r--r--games-arcade/stepmania/files/stepmania-3.9-newffmpeg.diff19
-rw-r--r--games-arcade/stepmania/stepmania-3.9.ebuild4
3 files changed, 27 insertions, 2 deletions
diff --git a/games-arcade/stepmania/ChangeLog b/games-arcade/stepmania/ChangeLog
index 05fc19a8b3fd..7643b239d064 100644
--- a/games-arcade/stepmania/ChangeLog
+++ b/games-arcade/stepmania/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/stepmania
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.21 2008/04/14 19:57:15 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.22 2008/06/21 13:20:46 hanno Exp $
+
+ 21 Jun 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/stepmania-3.9-newffmpeg.diff, stepmania-3.9.ebuild:
+ Fix paths for latest ffmpeg.
14 Apr 2008; Samuli Suominen <drac@gentoo.org> stepmania-3.9.ebuild:
Bumping patch level to 3 for bug 216128, GCC 4.3 compability patch by
diff --git a/games-arcade/stepmania/files/stepmania-3.9-newffmpeg.diff b/games-arcade/stepmania/files/stepmania-3.9-newffmpeg.diff
new file mode 100644
index 000000000000..dd6f9a408bfd
--- /dev/null
+++ b/games-arcade/stepmania/files/stepmania-3.9-newffmpeg.diff
@@ -0,0 +1,19 @@
+--- StepMania-3.9-src/src/arch/MovieTexture/MovieTexture_FFMpeg.cpp.1 2008-06-21 14:48:57.000000000 +0200
++++ StepMania-3.9-src/src/arch/MovieTexture/MovieTexture_FFMpeg.cpp 2008-06-21 14:49:16.000000000 +0200
+@@ -25,14 +25,14 @@
+ #else
+ extern "C"
+ {
+-#include <ffmpeg/avformat.h>
++#include <libavformat/avformat.h>
+ }
+ #endif
+
+ #if !defined(HAVE_IMG_CONVERT)
+ extern "C"
+ {
+-#include <ffmpeg/swscale.h>
++#include <libswscale/swscale.h>
+ }
+ #endif // HAVE_IMG_CONVERT
+ void img_convert__(AVPicture *dst, int dst_pix_fmt,
diff --git a/games-arcade/stepmania/stepmania-3.9.ebuild b/games-arcade/stepmania/stepmania-3.9.ebuild
index d665dbf4ebbb..3658b367ec9f 100644
--- a/games-arcade/stepmania/stepmania-3.9.ebuild
+++ b/games-arcade/stepmania/stepmania-3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.13 2008/04/14 19:57:15 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9.ebuild,v 1.14 2008/06/21 13:20:46 hanno Exp $
inherit autotools eutils games
@@ -50,6 +50,8 @@ src_unpack() {
EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patches
epatch "${T}"/gentoo.patch
+ epatch "${FILESDIR}/${P}-newffmpeg.diff"
+
AT_M4DIR="autoconf/m4"
eautoreconf
}