summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-15 18:10:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-15 18:10:27 +0000
commit89c26ed680dc902e28e8235b19670a488abeb882 (patch)
tree326e416cdedb23afa2103140fed2401b9690b099 /games-arcade
parentVersion bumped. (diff)
downloadgentoo-2-89c26ed680dc902e28e8235b19670a488abeb882.tar.gz
gentoo-2-89c26ed680dc902e28e8235b19670a488abeb882.tar.bz2
gentoo-2-89c26ed680dc902e28e8235b19670a488abeb882.zip
respect LDFLAGS (bug #337515)
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/alienwave/ChangeLog8
-rw-r--r--games-arcade/alienwave/alienwave-0.3.0.ebuild8
-rw-r--r--games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch2
3 files changed, 10 insertions, 8 deletions
diff --git a/games-arcade/alienwave/ChangeLog b/games-arcade/alienwave/ChangeLog
index 003b152abd7f..a478dfb8d9fd 100644
--- a/games-arcade/alienwave/ChangeLog
+++ b/games-arcade/alienwave/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/alienwave
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/alienwave/ChangeLog,v 1.11 2009/03/18 00:59:32 tcunha Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/alienwave/ChangeLog,v 1.12 2010/09/15 18:10:27 mr_bones_ Exp $
+
+ 15 Sep 2010; Michael Sterrett <mr_bones_@gentoo.org>
+ alienwave-0.3.0.ebuild, files/alienwave-0.3.0-gentoo.patch:
+ respect LDFLAGS (bug #337515)
18 Mar 2009; Tiago Cunha <tcunha@gentoo.org> alienwave-0.3.0.ebuild:
- Stable sparc.
diff --git a/games-arcade/alienwave/alienwave-0.3.0.ebuild b/games-arcade/alienwave/alienwave-0.3.0.ebuild
index fe534385f0eb..fa4b7956ff06 100644
--- a/games-arcade/alienwave/alienwave-0.3.0.ebuild
+++ b/games-arcade/alienwave/alienwave-0.3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/alienwave/alienwave-0.3.0.ebuild,v 1.13 2009/03/18 00:59:32 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/alienwave/alienwave-0.3.0.ebuild,v 1.14 2010/09/15 18:10:27 mr_bones_ Exp $
EAPI=2
inherit eutils games
@@ -18,9 +18,7 @@ DEPEND="sys-libs/ncurses"
S=${WORKDIR}/${PN}
-src_prepare() {
- epatch "${FILESDIR}"/${P}-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
src_install() {
dogamesbin alienwave || die "dogamesbin failed"
diff --git a/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch b/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch
index 3abdaf6a4d45..1b71f1cf1838 100644
--- a/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch
+++ b/games-arcade/alienwave/files/alienwave-0.3.0-gentoo.patch
@@ -16,7 +16,7 @@
alienwave: $(OBJS)
- $(CC) $(LIB) $(OBJS) -o alienwave
- strip alienwave
-+ $(CC) $(OBJS) $(LIB) -o alienwave
++ $(CC) $(OBJS) $(LDFLAGS) $(LIB) -o alienwave
main.o: main.c