summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-06-21 07:47:03 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-06-21 07:47:03 +0000
commit9db1b056a908ab061a70ad091d7da2d055f1b423 (patch)
tree373c37c120ffccc8a461c6042812e808467ce561 /games-arcade
parentmarked x86 per bug 422223 (diff)
downloadgentoo-2-9db1b056a908ab061a70ad091d7da2d055f1b423.tar.gz
gentoo-2-9db1b056a908ab061a70ad091d7da2d055f1b423.tar.bz2
gentoo-2-9db1b056a908ab061a70ad091d7da2d055f1b423.zip
Compile on gcc-4.7 Bug #421967
(Portage version: 2.1.10.65/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/blobby/ChangeLog6
-rw-r--r--games-arcade/blobby/blobby-0.9c.ebuild3
-rw-r--r--games-arcade/blobby/files/blobby-0.9c-gcc47.patch66
3 files changed, 73 insertions, 2 deletions
diff --git a/games-arcade/blobby/ChangeLog b/games-arcade/blobby/ChangeLog
index dc98a1e9dbff..322035d03e4e 100644
--- a/games-arcade/blobby/ChangeLog
+++ b/games-arcade/blobby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/blobby
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobby/ChangeLog,v 1.5 2012/05/04 04:22:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobby/ChangeLog,v 1.6 2012/06/21 07:47:03 tupone Exp $
+
+ 21 Jun 2012; Tupone Alfredo <tupone@gentoo.org> blobby-0.9c.ebuild,
+ +files/blobby-0.9c-gcc47.patch:
+ Compile on gcc-4.7 Bug #421967 by flameeyes@gentoo.org
04 May 2012; Jeff Horelick <jdhore@gentoo.org> blobby-0.9c.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-arcade/blobby/blobby-0.9c.ebuild b/games-arcade/blobby/blobby-0.9c.ebuild
index 7b67196eaa4b..687a52a2913d 100644
--- a/games-arcade/blobby/blobby-0.9c.ebuild
+++ b/games-arcade/blobby/blobby-0.9c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobby/blobby-0.9c.ebuild,v 1.5 2012/05/04 04:22:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/blobby/blobby-0.9c.ebuild,v 1.6 2012/06/21 07:47:03 tupone Exp $
EAPI=2
inherit cmake-utils eutils games
@@ -28,6 +28,7 @@ src_prepare() {
sed -i -e "s:share/${PN}:${GAMES_DATADIR}/${PN}:" data/CMakeLists.txt || die
sed -i -e "s:share/${PN}:${GAMES_DATADIR/\/usr\/}/${PN}:" src/main.cpp || die
sed -i -e "/DESTINATION/s:bin:${GAMES_BINDIR}:" src/CMakeLists.txt || die
+ epatch "${FILESDIR}"/${P}-gcc47.patch
}
src_configure() {
diff --git a/games-arcade/blobby/files/blobby-0.9c-gcc47.patch b/games-arcade/blobby/files/blobby-0.9c-gcc47.patch
new file mode 100644
index 000000000000..be873b7af0d1
--- /dev/null
+++ b/games-arcade/blobby/files/blobby-0.9c-gcc47.patch
@@ -0,0 +1,66 @@
+--- src/raknet/BinarySearchTree.h.old 2012-06-21 09:09:08.389412319 +0200
++++ src/raknet/BinarySearchTree.h 2012-06-21 09:10:39.830991876 +0200
+@@ -338,12 +338,12 @@
+ if ( current->left == 0 )
+ left_height = 0;
+ else
+- left_height = height( current->left );
++ left_height = this->height( current->left );
+
+ if ( current->right == 0 )
+ right_height = 0;
+ else
+- right_height = height( current->right );
++ right_height = this->height( current->right );
+
+ if ( right_height - left_height == 2 )
+ {
+@@ -371,7 +371,7 @@
+ if ( current == this->root )
+ break;
+
+- current = find_parent( *( current->item ) );
++ current = this->find_parent( *( current->item ) );
+
+ }
+ }
+@@ -400,7 +400,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->right ) > height( A->left );
++ return this->height( A->right ) > this->height( A->left );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -409,7 +409,7 @@
+ if ( A == 0 )
+ return false;
+
+- return height( A->left ) > height( A->right );
++ return this->height( A->left ) > this->height( A->right );
+ }
+
+ template <class BinarySearchTreeType>
+@@ -446,8 +446,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->right;
+
+ if ( A )
+@@ -510,8 +510,8 @@
+
+ */
+
+- B = find_parent( *( C->item ) );
+- A = find_parent( *( B->item ) );
++ B = this->find_parent( *( C->item ) );
++ A = this->find_parent( *( B->item ) );
+ D = C->left;
+
+ if ( A )