summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-28 21:00:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-28 21:00:13 +0000
commita1dd2507cc8a17a8600628b5f2fb5942fea1c547 (patch)
tree47bcedea016f576bf47db6327425c07070c983e9 /games-arcade
parentversion bump (diff)
downloadgentoo-2-a1dd2507cc8a17a8600628b5f2fb5942fea1c547.tar.gz
gentoo-2-a1dd2507cc8a17a8600628b5f2fb5942fea1c547.tar.bz2
gentoo-2-a1dd2507cc8a17a8600628b5f2fb5942fea1c547.zip
initial commit (bug #55745)
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/xjump/ChangeLog10
-rw-r--r--games-arcade/xjump/Manifest2
-rw-r--r--games-arcade/xjump/files/digest-xjump-2.7.52
-rw-r--r--games-arcade/xjump/metadata.xml5
-rw-r--r--games-arcade/xjump/xjump-2.7.5.ebuild52
5 files changed, 71 insertions, 0 deletions
diff --git a/games-arcade/xjump/ChangeLog b/games-arcade/xjump/ChangeLog
new file mode 100644
index 000000000000..3aca7814697c
--- /dev/null
+++ b/games-arcade/xjump/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-arcade/xjump
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xjump/ChangeLog,v 1.1 2005/03/28 21:00:13 mr_bones_ Exp $
+
+*xjump-2.7.5 (28 Mar 2005)
+
+ 28 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> +metadata.xml,
+ +xjump-2.7.5.ebuild:
+ initial commit (bug #55745)
+
diff --git a/games-arcade/xjump/Manifest b/games-arcade/xjump/Manifest
new file mode 100644
index 000000000000..6a2e6f2347c8
--- /dev/null
+++ b/games-arcade/xjump/Manifest
@@ -0,0 +1,2 @@
+MD5 577bd2692b6af6cc9d60b4b8f96391f2 xjump-2.7.5.ebuild 1262
+MD5 0c9248703c67b3d356fa4e306f7a6db6 files/digest-xjump-2.7.5 133
diff --git a/games-arcade/xjump/files/digest-xjump-2.7.5 b/games-arcade/xjump/files/digest-xjump-2.7.5
new file mode 100644
index 000000000000..e4c906041376
--- /dev/null
+++ b/games-arcade/xjump/files/digest-xjump-2.7.5
@@ -0,0 +1,2 @@
+MD5 3e8d09c6b8162b7e4380f8a77eb595dc xjump_2.7.5.orig.tar.gz 15940
+MD5 1484959d83c5f74dc629a05d58b8a087 xjump_2.7.5-1.2.diff.gz 5238
diff --git a/games-arcade/xjump/metadata.xml b/games-arcade/xjump/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-arcade/xjump/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-arcade/xjump/xjump-2.7.5.ebuild b/games-arcade/xjump/xjump-2.7.5.ebuild
new file mode 100644
index 000000000000..4fa2ae52daed
--- /dev/null
+++ b/games-arcade/xjump/xjump-2.7.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/xjump/xjump-2.7.5.ebuild,v 1.1 2005/03/28 21:00:13 mr_bones_ Exp $
+
+inherit games
+
+DEBIAN_PATCH="1.2"
+DESCRIPTION="An X game where one tries to jump up as many levels as possible."
+HOMEPAGE="http://packages.debian.org/stable/games/xjump"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV}-${DEBIAN_PATCH}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/x11"
+
+S=${WORKDIR}/${P}.orig
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Where we will keep the highscore file:
+ HISCORE_FILENAME=xjump.hiscores
+ HISCORE_FILE="${GAMES_STATEDIR}/${HISCORE_FILENAME}"
+
+ epatch "${WORKDIR}/${PN}_${PV}-${DEBIAN_PATCH}.diff"
+ epatch "${S}/debian/patches/"*.dpatch
+
+ # set up where we will keep the highscores file:
+ sed -i \
+ -e "/^CC/d" \
+ -e "/^CFLAGS/d" \
+ -e "s,/var/games/xjump,${GAMES_STATEDIR}," \
+ -e "s,/record,/${HISCORE_FILENAME}," \
+ Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ dogamesbin xjump || die "dogamesbin failed"
+ dodoc README.euc
+
+ # Set up the hiscores file:
+ dodir "${GAMES_STATEDIR}"
+ touch "${D}/${HISCORE_FILE}"
+ fperms 660 "${HISCORE_FILE}" || die "setting permissions failed"
+ prepgamesdirs
+}