summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-18 00:16:46 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-18 00:16:46 +0000
commitd0856f3bda6034ae5fe5026b17aea3083c999c6d (patch)
treee7a6a8e75a6ad321e13f5e2da175ddc978ca5927 /games-arcade
parentAdd missing lua dependency (#274447). (diff)
downloadgentoo-2-d0856f3bda6034ae5fe5026b17aea3083c999c6d.tar.gz
gentoo-2-d0856f3bda6034ae5fe5026b17aea3083c999c6d.tar.bz2
gentoo-2-d0856f3bda6034ae5fe5026b17aea3083c999c6d.zip
Fix building with gcc-4.4, bug #273500
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/yarsrevenge/ChangeLog8
-rw-r--r--games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch10
-rw-r--r--games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild17
3 files changed, 24 insertions, 11 deletions
diff --git a/games-arcade/yarsrevenge/ChangeLog b/games-arcade/yarsrevenge/ChangeLog
index 59a8d838e997..3916a3bc2dd7 100644
--- a/games-arcade/yarsrevenge/ChangeLog
+++ b/games-arcade/yarsrevenge/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/yarsrevenge
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/ChangeLog,v 1.9 2008/04/30 22:56:34 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/ChangeLog,v 1.10 2009/06/18 00:16:46 nyhm Exp $
+
+ 18 Jun 2009; Tristan Heaven <nyhm@gentoo.org> yarsrevenge-0.99.ebuild,
+ +files/yarsrevenge-0.99-gcc44.patch:
+ Fix building with gcc-4.4, bug #273500
30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+files/yarsrevenge-0.99-gcc43.patch, yarsrevenge-0.99.ebuild:
diff --git a/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch
new file mode 100644
index 000000000000..fca41cfbdf35
--- /dev/null
+++ b/games-arcade/yarsrevenge/files/yarsrevenge-0.99-gcc44.patch
@@ -0,0 +1,10 @@
+--- yar/game.cpp
++++ yar/game.cpp
+@@ -15,6 +15,7 @@
+ * *
+ ***************************************************************************/
+
++#include <cstdio>
+ #include "yar.hxx"
+
+
diff --git a/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
index 21d5feaaea24..1528391b71c2 100644
--- a/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
+++ b/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.9 2008/04/30 22:56:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/yarsrevenge/yarsrevenge-0.99.ebuild,v 1.10 2009/06/18 00:16:46 nyhm Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="remake of the Atari 2600 classic Yar's Revenge"
@@ -17,13 +18,11 @@ DEPEND="media-libs/libsdl"
S=${WORKDIR}/yar-${PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch \
- "${FILESDIR}"/${PV}-math.patch \
- "${FILESDIR}"/${P}-gcc43.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PV}-math.patch
+ "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc44.patch
+)
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"