summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-01-18 20:38:56 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-01-18 20:38:56 +0000
commit218a32e7d63503584107faea22ea2bda41526714 (patch)
tree068413c796c5bb329c2fa3c58b727ea7a20f0ce6 /games-board/ascal
parentClean up econf per bug #253596 and add missing deps. (diff)
downloadgentoo-2-218a32e7d63503584107faea22ea2bda41526714.tar.gz
gentoo-2-218a32e7d63503584107faea22ea2bda41526714.tar.bz2
gentoo-2-218a32e7d63503584107faea22ea2bda41526714.zip
Fix gcc-4.3 build bug #251125
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 i686)
Diffstat (limited to 'games-board/ascal')
-rw-r--r--games-board/ascal/ChangeLog9
-rw-r--r--games-board/ascal/ascal-0.1.1.ebuild7
-rw-r--r--games-board/ascal/files/ascal-0.1.1-gcc43.patch30
-rw-r--r--games-board/ascal/files/ascal-0.1.1-install.patch4
4 files changed, 43 insertions, 7 deletions
diff --git a/games-board/ascal/ChangeLog b/games-board/ascal/ChangeLog
index 46de56abd7f6..573b922ea563 100644
--- a/games-board/ascal/ChangeLog
+++ b/games-board/ascal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/ascal
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ascal/ChangeLog,v 1.2 2007/06/12 14:57:42 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/ascal/ChangeLog,v 1.3 2009/01/18 20:38:56 tupone Exp $
+
+ 18 Jan 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/ascal-0.1.1-gcc43.patch, files/ascal-0.1.1-install.patch,
+ ascal-0.1.1.ebuild:
+ Fix gcc-4.3 build bug #251125 by flameeyes@gentoo.org
12 Jun 2007; Tristan Heaven <nyhm@gentoo.org>
+files/ascal-0.1.1-install.patch, ascal-0.1.1.ebuild:
diff --git a/games-board/ascal/ascal-0.1.1.ebuild b/games-board/ascal/ascal-0.1.1.ebuild
index 18dc9e6b95e2..281457155b5a 100644
--- a/games-board/ascal/ascal-0.1.1.ebuild
+++ b/games-board/ascal/ascal-0.1.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ascal/ascal-0.1.1.ebuild,v 1.3 2007/06/12 14:57:42 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ascal/ascal-0.1.1.ebuild,v 1.4 2009/01/18 20:38:56 tupone Exp $
inherit autotools eutils games
@@ -22,7 +22,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-install.patch
+ epatch "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}
diff --git a/games-board/ascal/files/ascal-0.1.1-gcc43.patch b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
new file mode 100644
index 000000000000..4b3829ec46a5
--- /dev/null
+++ b/games-board/ascal/files/ascal-0.1.1-gcc43.patch
@@ -0,0 +1,30 @@
+--- src/gui.cpp.old 2009-01-18 21:11:58.000000000 +0100
++++ src/gui.cpp 2009-01-18 21:12:33.000000000 +0100
+@@ -21,6 +21,7 @@
+ #include "shareddata.hpp"
+ #include "config.h"
+ #include <string>
++#include <libintl.h>
+
+ gui::gui(shareddata *newData): GuiBoard() {
+ //clean, cleaner - pointer ;)
+--- src/gui_board.cpp.old 2009-01-18 21:13:30.000000000 +0100
++++ src/gui_board.cpp 2009-01-18 21:13:50.000000000 +0100
+@@ -20,6 +20,7 @@
+ #include <math.h>
+ #include "helper.h"
+ #include <stack>
++#include <libintl.h>
+
+
+ gui_board::gui_board() {
+--- src/board.cpp.old 2009-01-18 21:14:27.000000000 +0100
++++ src/board.cpp 2009-01-18 21:14:58.000000000 +0100
+@@ -15,6 +15,7 @@
+ // Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+ #include "board.hpp"
++#include <cstdlib>
+ //#define DEBUG
+ #include "ourmove.hpp"
+ #include "helper.h"
diff --git a/games-board/ascal/files/ascal-0.1.1-install.patch b/games-board/ascal/files/ascal-0.1.1-install.patch
index 86c7659feeb1..b4902998f65f 100644
--- a/games-board/ascal/files/ascal-0.1.1-install.patch
+++ b/games-board/ascal/files/ascal-0.1.1-install.patch
@@ -30,7 +30,7 @@
--- Makefile.am
+++ Makefile.am
-@@ -17,13 +17,13 @@
+@@ -17,13 +17,12 @@
ACLOCAL_AMFLAGS = -I m4
@@ -41,7 +41,7 @@
-desktopdir = $(datadir)/applications
+desktopdir = /usr/share/applications
desktop_in_files = ascal.desktop.in
- desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+-desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@