summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-31 06:54:36 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-31 06:54:36 +0000
commited6f27cb8a59962b2ac8c17bc58834e6b51a51e2 (patch)
tree65823781b41b9de07b06ea08c8c041a2b8c3b822 /games-board/crafty
parentversion bump. This incorporates Eric Raymond's latest iteration of the /etc/... (diff)
downloadgentoo-2-ed6f27cb8a59962b2ac8c17bc58834e6b51a51e2.tar.gz
gentoo-2-ed6f27cb8a59962b2ac8c17bc58834e6b51a51e2.tar.bz2
gentoo-2-ed6f27cb8a59962b2ac8c17bc58834e6b51a51e2.zip
ver bump #34789
Diffstat (limited to 'games-board/crafty')
-rw-r--r--games-board/crafty/ChangeLog11
-rw-r--r--games-board/crafty/crafty-19.8.ebuild71
-rw-r--r--games-board/crafty/files/19.8-ppc.patch25
-rw-r--r--games-board/crafty/files/digest-crafty-19.81
4 files changed, 105 insertions, 3 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 61cdb5562a10..08cb79ce4f99 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.3 2003/12/13 18:02:04 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.4 2003/12/31 06:54:35 vapier Exp $
+
+*crafty-19.8 (31 Dec 2003)
+
+ 31 Dec 2003; Mike Frysinger <vapier@gentoo.org> :
+ Update to 19.8 and clean up #34789.
+
+*crafty-19.1 (25 Oct 2002)
13 Dec 2003; Brad House <brad_mssw@gentoo.org> crafty-19.1.ebuild:
mark stable on amd64
-*crafty-19.1.ebuild (25 Oct 2002)
-
25 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
Update to 19.1 per #9657.
diff --git a/games-board/crafty/crafty-19.8.ebuild b/games-board/crafty/crafty-19.8.ebuild
new file mode 100644
index 000000000000..623c3da3a4a0
--- /dev/null
+++ b/games-board/crafty/crafty-19.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-19.8.ebuild,v 1.1 2003/12/31 06:54:35 vapier Exp $
+
+inherit games eutils flag-o-matic
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/v19/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="icc no-opts"
+
+DEPEND="virtual/glibc
+ icc? ( >=dev-lang/icc-5.0 )"
+RDEPEND="virtual/glibc"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i '/-o crafty/s/CC/CXX/' Makefile
+ epatch ${FILESDIR}/${PV}-ppc.patch #5932
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+ if [ ! `use no-opts` ] ; then
+ if [ `use icc` ] ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [ "${CHOST}" == "i686-pc-linux-gnu" ] || [ "${CHOST}" == "i586-pc-linux-gnu" ] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fforce-mem -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="-lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ einfo
+ einfo "Note: No books or tablebases have been installed. If you want them, just"
+ einfo " download them from ${HOMEPAGE}."
+ einfo " You will find documentation there too. In most cases you take now "
+ einfo " your xboard compatible application, (xboard, eboard, knights) and "
+ einfo " just play chess against computer opponent. Have fun."
+ einfo
+}
diff --git a/games-board/crafty/files/19.8-ppc.patch b/games-board/crafty/files/19.8-ppc.patch
new file mode 100644
index 000000000000..c337e108a473
--- /dev/null
+++ b/games-board/crafty/files/19.8-ppc.patch
@@ -0,0 +1,25 @@
+--- utility.c.orig 2003-12-31 01:36:43.778210312 -0500
++++ utility.c 2003-12-31 01:37:50.667041664 -0500
+@@ -1134,13 +1134,19 @@
+ }
+
+ void Print(int vb, char *fmt, ...) {
+- va_list ap;
++ va_list ap, ap2;
+ va_start(ap,fmt);
++ #ifdef __va_copy
++ __va_copy(ap2, ap);
++ #else
++ /* FIXME: C99 has va_copy() - test for C99 and use it if present */
++ ap2 = ap;
++ #endif
+ if (vb&display_options) vprintf(fmt, ap);
+ fflush(stdout);
+ if (time_limit>99 || tc_time_remaining>6000 || vb==4095) {
+- va_start(ap,fmt);
+- if (log_file) vfprintf(log_file, fmt, ap);
++ va_start(ap2,fmt);
++ if (log_file) vfprintf(log_file, fmt, ap2);
+ if (log_file) fflush(log_file);
+ }
+ va_end(ap);
diff --git a/games-board/crafty/files/digest-crafty-19.8 b/games-board/crafty/files/digest-crafty-19.8
new file mode 100644
index 000000000000..d1d2e5735c3c
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-19.8
@@ -0,0 +1 @@
+MD5 eb7f48d1f8acc3804e80291d85b1ec35 crafty-19.8.tar.gz 384312