summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2006-01-03 02:19:43 +0000
committerMark Loeser <halcy0n@gentoo.org>2006-01-03 02:19:43 +0000
commit1cebab17c95acbd86524e635b25a568b0be93efe (patch)
tree196cb5e8cf07725a3a2f61b46e2babf79d23d883 /games-board/eboard
parentFix qmake path error from bug #103589 (diff)
downloadgentoo-2-1cebab17c95acbd86524e635b25a568b0be93efe.tar.gz
gentoo-2-1cebab17c95acbd86524e635b25a568b0be93efe.tar.bz2
gentoo-2-1cebab17c95acbd86524e635b25a568b0be93efe.zip
Fix compilation with gcc-4 on 64 bit platforms. Patch by Dario Birtic <dariobirtic AT gmx DOT net>; bug #112131
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'games-board/eboard')
-rw-r--r--games-board/eboard/ChangeLog9
-rw-r--r--games-board/eboard/Manifest15
-rw-r--r--games-board/eboard/eboard-0.9.5.ebuild7
-rw-r--r--games-board/eboard/files/eboard-0.9.5-gcc4.patch44
4 files changed, 59 insertions, 16 deletions
diff --git a/games-board/eboard/ChangeLog b/games-board/eboard/ChangeLog
index 69e26bda25ba..33c228be9218 100644
--- a/games-board/eboard/ChangeLog
+++ b/games-board/eboard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/eboard
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/eboard/ChangeLog,v 1.11 2005/08/16 14:53:28 gustavoz Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/eboard/ChangeLog,v 1.12 2006/01/03 02:19:43 halcy0n Exp $
+
+ 03 Jan 2006; Mark Loeser <halcy0n@gentoo.org>
+ +files/eboard-0.9.5-gcc4.patch, eboard-0.9.5.ebuild:
+ Fix compilation with gcc-4 on 64 bit platforms. Patch by Dario Birtic
+ <dariobirtic AT gmx DOT net>; bug #112131
16 Aug 2005; Gustavo Zacarias <gustavoz@gentoo.org> eboard-0.9.5.ebuild:
Stable on sparc
diff --git a/games-board/eboard/Manifest b/games-board/eboard/Manifest
index 6127814e6e7f..4c9d40f0df89 100644
--- a/games-board/eboard/Manifest
+++ b/games-board/eboard/Manifest
@@ -1,14 +1,5 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 a8f1ffc950e6ce94583fb88ddd1b92cb eboard-0.9.5.ebuild 1835
MD5 7c4dd5de233fdbfc6ea51d256114c286 ChangeLog 2682
+MD5 972a419814fa2f39c3119ad76b1ec00f eboard-0.9.5.ebuild 1875
MD5 f37e8356d4b5cb9585c1bdae8dcd889c files/digest-eboard-0.9.5 201
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1-ecc0.1.6 (GNU/Linux)
-
-iD8DBQFDAf4nKRy60XGEcJIRAgfJAJsG1PpKJgKbXmas9sB+U0NrgKqNygCgpgXK
-+mSd3Bw2CXcBA5vXCLRL4Xw=
-=0xYw
------END PGP SIGNATURE-----
+MD5 a1dc527f388a26579a14ec853e326124 files/eboard-0.9.5-gcc4.patch 1634
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
diff --git a/games-board/eboard/eboard-0.9.5.ebuild b/games-board/eboard/eboard-0.9.5.ebuild
index e5a1c6b9978e..3b5a8a3e6cf7 100644
--- a/games-board/eboard/eboard-0.9.5.ebuild
+++ b/games-board/eboard/eboard-0.9.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/eboard/eboard-0.9.5.ebuild,v 1.9 2005/08/16 14:53:28 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/eboard/eboard-0.9.5.ebuild,v 1.10 2006/01/03 02:19:43 halcy0n Exp $
inherit eutils games
@@ -27,6 +27,9 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd ${S}
+
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+
sed -i \
-e "/DATADIR/ s:\$prefix/share:${GAMES_DATADIR}:" \
-e "s:(\"-O6\"):split(' ', \"${CXXFLAGS}\"):" configure \
diff --git a/games-board/eboard/files/eboard-0.9.5-gcc4.patch b/games-board/eboard/files/eboard-0.9.5-gcc4.patch
new file mode 100644
index 000000000000..b761591f19aa
--- /dev/null
+++ b/games-board/eboard/files/eboard-0.9.5-gcc4.patch
@@ -0,0 +1,44 @@
+--- eboard-0.9.5/board.cc.orig 2005-11-11 02:18:41.000000000 +0100
++++ eboard-0.9.5/board.cc 2005-11-11 02:19:20.000000000 +0100
+@@ -1059,8 +1059,8 @@
+ cerr.setf(ios::hex,ios::basefield);
+ cerr.setf(ios::showbase);
+
+- cerr << "[board " << ((unsigned int)this) << "] ";
+- cerr << "game=[" << ((unsigned int)mygame) << "] ";
++ cerr << "[board " << ((unsigned long)this) << "] ";
++ cerr << "game=[" << ((unsigned long)mygame) << "] ";
+
+ cerr.setf(ios::dec,ios::basefield);
+ cerr << "paneid=" << getPageId() << endl;
+--- eboard-0.9.5/chess.cc.orig 2005-11-11 02:19:45.000000000 +0100
++++ eboard-0.9.5/chess.cc 2005-11-11 02:20:02.000000000 +0100
+@@ -641,7 +641,7 @@
+ cerr.setf(ios::hex,ios::basefield);
+ cerr.setf(ios::showbase);
+
+- cerr << "[game " << ((unsigned int)this) << "] ";
++ cerr << "[game " << ((unsigned long)this) << "] ";
+
+ cerr.setf(ios::dec,ios::basefield);
+
+@@ -655,7 +655,7 @@
+ cerr.setf(ios::hex,ios::basefield);
+ cerr.setf(ios::showbase);
+
+- cerr << "board=[" << ((unsigned int)myboard) << "]" << endl;
++ cerr << "board=[" << ((unsigned long)myboard) << "]" << endl;
+ }
+
+ char * ChessGame::getPlayerString(int index) {
+--- eboard-0.9.5/notebook.cc.orig 2005-11-11 02:20:41.000000000 +0100
++++ eboard-0.9.5/notebook.cc 2005-11-11 02:20:54.000000000 +0100
+@@ -127,7 +127,7 @@
+ void Page::dump() {
+ cerr.setf(ios::hex,ios::basefield);
+ cerr.setf(ios::showbase);
+- cerr << "[page " << ((unsigned int)this) << "] ";
++ cerr << "[page " << ((unsigned long)this) << "] ";
+ cerr.setf(ios::dec,ios::basefield);
+ cerr << "pageid=" << number << " ";
+ cerr << "title=" << title << " ";