summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-04 07:31:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-04 07:31:46 +0000
commit4988e7f31043612f12f1d4b36a6831db13f2cd12 (patch)
tree384f2eb624ba1026538ca6ba5bb1457d087f17ad /games-board/grhino/grhino-0.16.1.ebuild
parentVersion bump (diff)
downloadgentoo-2-4988e7f31043612f12f1d4b36a6831db13f2cd12.tar.gz
gentoo-2-4988e7f31043612f12f1d4b36a6831db13f2cd12.tar.bz2
gentoo-2-4988e7f31043612f12f1d4b36a6831db13f2cd12.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-board/grhino/grhino-0.16.1.ebuild')
-rw-r--r--games-board/grhino/grhino-0.16.1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/games-board/grhino/grhino-0.16.1.ebuild b/games-board/grhino/grhino-0.16.1.ebuild
new file mode 100644
index 000000000000..ad44ce15614f
--- /dev/null
+++ b/games-board/grhino/grhino-0.16.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/grhino/grhino-0.16.1.ebuild,v 1.1 2010/09/04 07:31:46 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
+HOMEPAGE="http://rhino.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome gtp nls"
+
+RDEPEND="gnome? ( =gnome-base/libgnomeui-2* )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ sed -i '/^(\|locale\|help\|omf\|icon\|)/s:@datadir@:/usr/share:' \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_configure() {
+ if use gnome || use gtp; then
+ egamesconf \
+ --localedir=/usr/share/locale \
+ $(use_enable gnome) \
+ $(use_enable gtp) \
+ $(use_enable nls)
+ else
+ egamesconf \
+ --localedir=/usr/share/locale \
+ --enable-gtp \
+ --disable-gnome \
+ $(use_enable nls)
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc ChangeLog NEWS README TODO
+
+ if use gnome; then
+ make_desktop_entry ${PN} GRhino
+ fi
+
+ prepgamesdirs
+}