summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-05-20 00:52:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-05-20 00:52:42 +0000
commitac05506ba41cfc75fa342f903fbbbb302775e67f (patch)
tree78e70e69ad5722af8f2d5f1434bc0c97629877b5 /games-board/mah-jong
parentVersion bump. (diff)
downloadgentoo-2-ac05506ba41cfc75fa342f903fbbbb302775e67f.tar.gz
gentoo-2-ac05506ba41cfc75fa342f903fbbbb302775e67f.tar.bz2
gentoo-2-ac05506ba41cfc75fa342f903fbbbb302775e67f.zip
version bump (bug #496956)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board/mah-jong')
-rw-r--r--games-board/mah-jong/ChangeLog7
-rw-r--r--games-board/mah-jong/mah-jong-1.14.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/games-board/mah-jong/ChangeLog b/games-board/mah-jong/ChangeLog
index 50cf1d322bea..1a155872fbfd 100644
--- a/games-board/mah-jong/ChangeLog
+++ b/games-board/mah-jong/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/mah-jong
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.23 2014/05/16 01:06:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.24 2014/05/20 00:52:42 mr_bones_ Exp $
+
+*mah-jong-1.14 (20 May 2014)
+
+ 20 May 2014; Michael Sterrett <mr_bones_@gentoo.org> +mah-jong-1.14.ebuild:
+ version bump (bug #496956)
16 May 2014; Michael Sterrett <mr_bones_@gentoo.org> mah-jong-1.12.1.ebuild:
EAPI=5; tidy; dirty -lm fix
diff --git a/games-board/mah-jong/mah-jong-1.14.ebuild b/games-board/mah-jong/mah-jong-1.14.ebuild
new file mode 100644
index 000000000000..b50b7a3836eb
--- /dev/null
+++ b/games-board/mah-jong/mah-jong-1.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.14.ebuild,v 1.1 2014/05/20 00:52:42 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs games
+
+MY_P="mj-${PV}-src"
+DESCRIPTION="A networked Mah Jong program, together with a computer player"
+HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
+SRC_URI="http://mahjong.julianbradfield.org/Source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e '/^.TH/ s/1/6/' xmj.man || die
+ sed -i \
+ -e "/^DESTDIR =/ s:=.*:= ${D}:" \
+ -e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
+ -e '/^MANDIR =/ s:man/man1:/usr/share/man/man6:' \
+ -e '/^MANSUFFIX =/ s:1:6:' \
+ -e "/^CC =/ s:gcc:$(tc-getCC):" \
+ -e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
+ -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
+ -e '/^INSTPGMFLAGS =/ s:-s::' \
+ -e '/^CDEBUGFLAGS =/d' \
+ -e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile || die
+}
+
+src_install() {
+ emake install install.man
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r fallbacktiles/ tiles-numbered/ tiles-small/
+ newicon tiles-v1/tongE.xpm ${PN}.xpm
+ make_desktop_entry xmj Mah-Jong ${PN}
+ dodoc CHANGES ChangeLog *.txt
+ prepgamesdirs
+}