summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-12-12 22:40:27 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-12-12 22:40:27 +0000
commit052f2826460d0b831aaa49d7a0d91811f9299a97 (patch)
tree3901f0a07ff8b325c839fce7129045541ee7a618 /games-board
parentAdded local USE flag zippy for xboard. (diff)
downloadgentoo-2-052f2826460d0b831aaa49d7a0d91811f9299a97.tar.gz
gentoo-2-052f2826460d0b831aaa49d7a0d91811f9299a97.tar.bz2
gentoo-2-052f2826460d0b831aaa49d7a0d91811f9299a97.zip
Added an updated ebuild from Ali Polatel <polatel@nerdshack.com> and closing bug #157875.
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/xboard/ChangeLog9
-rw-r--r--games-board/xboard/files/digest-xboard-4.2.7-r16
-rw-r--r--games-board/xboard/xboard-4.2.7-r1.ebuild56
3 files changed, 70 insertions, 1 deletions
diff --git a/games-board/xboard/ChangeLog b/games-board/xboard/ChangeLog
index ef66ff1ade47..c576a1f356c0 100644
--- a/games-board/xboard/ChangeLog
+++ b/games-board/xboard/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-board/xboard
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/ChangeLog,v 1.11 2006/10/20 22:14:59 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/ChangeLog,v 1.12 2006/12/12 22:40:27 wolf31o2 Exp $
+
+*xboard-4.2.7-r1 (12 Dec 2006)
+
+ 12 Dec 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +xboard-4.2.7-r1.ebuild:
+ Added an updated ebuild from Ali Polatel <polatel@nerdshack.com> and closing
+ bug #157875.
20 Oct 2006; <tupone@gentoo.org> xboard-4.2.7.ebuild:
Test phase restricted. Bug #124112 by Matthew Wesley
diff --git a/games-board/xboard/files/digest-xboard-4.2.7-r1 b/games-board/xboard/files/digest-xboard-4.2.7-r1
new file mode 100644
index 000000000000..ef8f12ca4e12
--- /dev/null
+++ b/games-board/xboard/files/digest-xboard-4.2.7-r1
@@ -0,0 +1,6 @@
+MD5 b70ad8ff7569975302c5fb402d5eea32 xboard-4.2.7.tar.gz 1318110
+RMD160 bd05a47319a35f7024a1743bea622e26052f4d28 xboard-4.2.7.tar.gz 1318110
+SHA256 5b21f12e3e99be0c69a3fa5f3d4cb79def24b6a2195ed94efc1b6ab415fb8d3b xboard-4.2.7.tar.gz 1318110
+MD5 08f3d0fed0c5bc2b52c4aad41f18982b xboard.png 479
+RMD160 d0e7fa9cc30e2cf58c13eaf08f2d576e2ea9b076 xboard.png 479
+SHA256 1c36fd6ca934eef29d7cdc72159019585d8c449f489f6a6ccc2d787bba03f41d xboard.png 479
diff --git a/games-board/xboard/xboard-4.2.7-r1.ebuild b/games-board/xboard/xboard-4.2.7-r1.ebuild
new file mode 100644
index 000000000000..131f26657e17
--- /dev/null
+++ b/games-board/xboard/xboard-4.2.7-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/xboard/xboard-4.2.7-r1.ebuild,v 1.1 2006/12/12 22:40:27 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="GUI for gnuchess and for internet chess servers"
+HOMEPAGE="http://www.tim-mann.org/xboard.html"
+SRC_URI="mirror://gnu/xboard/${P}.tar.gz
+ mirror://gentoo/${PN}.png
+ http://dev.gentoo.org/~wolf31o2/sources/dump/${PN}.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="Xaw3d zippy"
+RESTRICT="test" #124112
+
+RDEPEND="Xaw3d? ( x11-libs/Xaw3d )
+ x11-libs/libXaw
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXmu
+ x11-libs/libXext
+ x11-libs/libICE"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}*
+}
+
+src_compile() {
+ egamesconf $(use_with Xaw3d) \
+ $(use_enable zippy) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc FAQ READ_ME ToDo ChangeLog*
+ use zippy && dodoc zippy.README
+ dohtml FAQ.html
+ doicon ${DISTDIR}/xboard.png
+ make_desktop_entry ${PN} "Xboard (Chess)"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ elog "No chess engines are emerged by default! If you want a chess engine"
+ elog "to play with, you can emerge gnuchess or crafty."
+ elog "Read xboard FAQ for information."
+}