summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-05-18 07:57:34 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-05-18 07:57:34 +0000
commit16e78d0c4ea8cdac0b36802a6a35812d9b50ff1c (patch)
tree43c91ffa58d6acc5e6d6df2e2f987ffee0eb5a8c /games-board
parentRemove wineesd.drv.so as amd64 emul libs don't include the esound libraries a... (diff)
downloadgentoo-2-16e78d0c4ea8cdac0b36802a6a35812d9b50ff1c.tar.gz
gentoo-2-16e78d0c4ea8cdac0b36802a6a35812d9b50ff1c.tar.bz2
gentoo-2-16e78d0c4ea8cdac0b36802a6a35812d9b50ff1c.zip
Fix build with gcc-4.5. Bug #318601
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/openyahtzee/ChangeLog6
-rw-r--r--games-board/openyahtzee/files/openyahtzee-1.9-gcc45.patch20
-rw-r--r--games-board/openyahtzee/openyahtzee-1.9.ebuild5
3 files changed, 28 insertions, 3 deletions
diff --git a/games-board/openyahtzee/ChangeLog b/games-board/openyahtzee/ChangeLog
index 3770ff761ad5..4fd489624871 100644
--- a/games-board/openyahtzee/ChangeLog
+++ b/games-board/openyahtzee/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/openyahtzee
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/ChangeLog,v 1.11 2010/01/24 23:08:31 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/ChangeLog,v 1.12 2010/05/18 07:57:34 tupone Exp $
+
+ 18 May 2010; Tupone Alfredo <tupone@gentoo.org> openyahtzee-1.9.ebuild,
+ +files/openyahtzee-1.9-gcc45.patch:
+ Fix build with gcc-4.5. Bug #318601 by flameeyes@gentoo.org
24 Jan 2010; Brent Baude <ranger@gentoo.org> openyahtzee-1.9.ebuild:
keyworded ~arch for ppc, bug 296287
diff --git a/games-board/openyahtzee/files/openyahtzee-1.9-gcc45.patch b/games-board/openyahtzee/files/openyahtzee-1.9-gcc45.patch
new file mode 100644
index 000000000000..4aa411bfec5a
--- /dev/null
+++ b/games-board/openyahtzee/files/openyahtzee-1.9-gcc45.patch
@@ -0,0 +1,20 @@
+--- src/DBwrapper.cpp.old 2010-05-18 09:47:25.000000000 +0200
++++ src/DBwrapper.cpp 2010-05-18 09:47:50.000000000 +0200
+@@ -96,7 +96,7 @@
+ cerr << "sqlite3_compile error:" <<endl;
+ cerr << sqlite3_errmsg( m_db ) <<endl;
+ cerr << "on insert: " << query <<endl;
+- values = list<string>::list();
++ values = list<string>();
+ } else {
+ int busyCnt = 0;
+ int number = sqlite3_column_count( stmt );
+@@ -138,7 +138,7 @@
+ cerr << "sqlite_step error.\n";
+ cerr << sqlite3_errmsg( m_db ) << endl;
+ cerr << "on query: " << query << endl;
+- values = list<string>::list();
++ values = list<string>();
+ }
+ }
+
diff --git a/games-board/openyahtzee/openyahtzee-1.9.ebuild b/games-board/openyahtzee/openyahtzee-1.9.ebuild
index c38659835eca..ceaa38d00b79 100644
--- a/games-board/openyahtzee/openyahtzee-1.9.ebuild
+++ b/games-board/openyahtzee/openyahtzee-1.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/openyahtzee-1.9.ebuild,v 1.5 2010/01/24 23:08:31 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/openyahtzee/openyahtzee-1.9.ebuild,v 1.6 2010/05/18 07:57:34 tupone Exp $
EAPI=2
WX_GTK_VER="2.8"
-inherit autotools wxwidgets games
+inherit eutils autotools wxwidgets games
DESCRIPTION="A full-featured wxWidgets version of the classic dice game Yahtzee"
HOMEPAGE="http://openyahtzee.sourceforge.net/"
@@ -18,6 +18,7 @@ IUSE=""
DEPEND="x11-libs/wxGTK:2.8[X]"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
sed -i \
-e 's:openyahtzee_LDFLAGS:openyahtzee_LDADD:' \
src/Makefile.am || die