summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-08 18:41:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-08 18:41:58 +0000
commit7960dab88725ed732bc7b31927e5bcdb0813990e (patch)
tree87b225b531c4e319acaffbbc913789285cd2b96f /games-board
parent* bump (diff)
downloadgentoo-2-7960dab88725ed732bc7b31927e5bcdb0813990e.tar.gz
gentoo-2-7960dab88725ed732bc7b31927e5bcdb0813990e.tar.bz2
gentoo-2-7960dab88725ed732bc7b31927e5bcdb0813990e.zip
Add in upstream patch and sed patch to fix bug #135885
(Portage version: 2.1_rc4-r4)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mahjongg3d/ChangeLog6
-rw-r--r--games-board/mahjongg3d/files/digest-mahjongg3d-0.965
-rw-r--r--games-board/mahjongg3d/mahjongg3d-0.96.ebuild16
3 files changed, 21 insertions, 6 deletions
diff --git a/games-board/mahjongg3d/ChangeLog b/games-board/mahjongg3d/ChangeLog
index d85a1fe091e1..948ba308b1fe 100644
--- a/games-board/mahjongg3d/ChangeLog
+++ b/games-board/mahjongg3d/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/mahjongg3d
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/ChangeLog,v 1.8 2006/02/09 13:55:10 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/ChangeLog,v 1.9 2006/06/08 18:41:57 mr_bones_ Exp $
+
+ 08 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ mahjongg3d-0.96.ebuild:
+ Add in upstream patch and sed patch to fix bug #135885
09 Feb 2006; Caleb Tennis <caleb@gentoo.org> mahjongg3d-0.96.ebuild:
Fix qmake call to get the Qt3 version
diff --git a/games-board/mahjongg3d/files/digest-mahjongg3d-0.96 b/games-board/mahjongg3d/files/digest-mahjongg3d-0.96
index 2f340eea5262..56d19dc59c65 100644
--- a/games-board/mahjongg3d/files/digest-mahjongg3d-0.96
+++ b/games-board/mahjongg3d/files/digest-mahjongg3d-0.96
@@ -1 +1,6 @@
+MD5 e598e9cc237342702d9b1b273490b0de mahjongg3d-0.96-patch2.tar.bz2 2950
+RMD160 8c5cf6a229df528289bf22b2358a60e1fcfc43d0 mahjongg3d-0.96-patch2.tar.bz2 2950
+SHA256 df5a2f8b33a59ef19c56523db03786df8c00b2df2fdf79d1da68b57889b40ebe mahjongg3d-0.96-patch2.tar.bz2 2950
MD5 f5a08f4d1f375f3e4e94a2d392fe21d7 mahjongg3d-0.96.tar.bz2 4906036
+RMD160 17e9fe495a7aa661e2dd6e2dff07f12c04cf2fb8 mahjongg3d-0.96.tar.bz2 4906036
+SHA256 011719dd78977fcd7745abd949d92c7dd2a44f480f2468e9aa14a0ca95e704ca mahjongg3d-0.96.tar.bz2 4906036
diff --git a/games-board/mahjongg3d/mahjongg3d-0.96.ebuild b/games-board/mahjongg3d/mahjongg3d-0.96.ebuild
index b830aefe9b78..1c025b6713fd 100644
--- a/games-board/mahjongg3d/mahjongg3d-0.96.ebuild
+++ b/games-board/mahjongg3d/mahjongg3d-0.96.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/mahjongg3d-0.96.ebuild,v 1.7 2006/02/09 13:55:10 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/mahjongg3d/mahjongg3d-0.96.ebuild,v 1.8 2006/06/08 18:41:57 mr_bones_ Exp $
-inherit kde games
+inherit eutils kde games
DESCRIPTION="An implementation of the classical chinese game Mah Jongg with 3D OpenGL graphics"
HOMEPAGE="http://www.reto-schoelly.de/mahjongg3d/"
-SRC_URI="http://www.reto-schoelly.de/${PN}/${P}.tar.bz2"
+SRC_URI="http://www.reto-schoelly.de/${PN}/${P}.tar.bz2
+ http://www.reto-schoelly.de/mahjongg3d/${P}-patch2.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -19,16 +20,21 @@ DEPEND="$(qt_min_version 3.2)
S=${WORKDIR}/${PN}.release
src_unpack() {
- unpack ${A}
+ unpack ${P}.tar.bz2
cd "${S}"
+ unpack ${P}-patch2.tar.bz2
sed -i \
-e "/GAMEDATA_BASE_PATH/ s:\.:${GAMES_DATADIR}/${PN}:" \
src/gamedata_path.h \
|| die "sed failed"
+ #bug #135885
+ sed -i \
+ -e 's/openglwidget.h/OpenGLWidget.h/' src/MainDialogBase.ui \
+ || die "sed failed"
}
src_compile() {
- qmake QMAKE=${QTDIR}/bin/qmake -o Makefile mahjongg3d.pro
+ qmake QMAKE="${QTDIR}"/bin/qmake -o Makefile mahjongg3d.pro
kde_src_compile none
emake || die "emake failed"
}