summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2012-07-29 20:53:09 +0000
committerDenis Dupeyron <calchan@gentoo.org>2012-07-29 20:53:09 +0000
commit7ce634ffcbcf58336da7fed950bce4cbcc7658d7 (patch)
tree45649b85cf5139d1536d1f22b0967bdf255031dc /games-board
parentrespect CFLAGS wrt #428538 (diff)
downloadgentoo-2-7ce634ffcbcf58336da7fed950bce4cbcc7658d7.tar.gz
gentoo-2-7ce634ffcbcf58336da7fed950bce4cbcc7658d7.tar.bz2
gentoo-2-7ce634ffcbcf58336da7fed950bce4cbcc7658d7.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/mah-jong/ChangeLog9
-rw-r--r--games-board/mah-jong/mah-jong-1.12.1.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/games-board/mah-jong/ChangeLog b/games-board/mah-jong/ChangeLog
index 34f407020ef3..e3f8d3251f8b 100644
--- a/games-board/mah-jong/ChangeLog
+++ b/games-board/mah-jong/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/mah-jong
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.17 2010/02/27 18:07:13 phajdan.jr Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/ChangeLog,v 1.18 2012/07/29 20:53:09 calchan Exp $
+
+*mah-jong-1.12.1 (29 Jul 2012)
+
+ 29 Jul 2012; Denis Dupeyron <calchan@gentoo.org> +mah-jong-1.12.1.ebuild:
+ Version bump.
27 Feb 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> mah-jong-1.10.ebuild:
x86 stable wrt bug #303835
diff --git a/games-board/mah-jong/mah-jong-1.12.1.ebuild b/games-board/mah-jong/mah-jong-1.12.1.ebuild
new file mode 100644
index 000000000000..df07b93a6f6b
--- /dev/null
+++ b/games-board/mah-jong/mah-jong-1.12.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/mah-jong/mah-jong-1.12.1.ebuild,v 1.1 2012/07/29 20:53:09 calchan Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs games
+
+MY_P="mj-${PV}-src"
+DESCRIPTION="A networked Mah Jong program, together with a computer player"
+HOMEPAGE="http://www.stevens-bradfield.com/MahJong/"
+SRC_URI="http://mahjong.julianbradfield.org/Source/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i \
+ -e '/^.TH/ s/1/6/' xmj.man \
+ || die "sed failed"
+ sed -i \
+ -e "/^DESTDIR =/ s:=.*:= ${D}:" \
+ -e "/^BINDIR =/ s:=.*:= ${GAMES_BINDIR}:" \
+ -e '/^MANDIR =/ s:man/man1:/usr/share/man/man6:' \
+ -e '/^MANSUFFIX =/ s:1:6:' \
+ -e "/^CC =/ s:gcc:$(tc-getCC):" \
+ -e "/^CFLAGS =/ s:=:= ${CFLAGS}:" \
+ -e "/^LDLIBS =/ s:$:${LDFLAGS}:" \
+ -e '/^INSTPGMFLAGS =/ s:-s::' \
+ -e '/^CDEBUGFLAGS =/d' \
+ -e "/^TILESETPATH=/ s:NULL:\"${GAMES_DATADIR}/${PN}/\":" Makefile \
+ || die "sed failed"
+}
+
+src_install() {
+ emake install install.man || die "emake install failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r fallbacktiles/ tiles-numbered/ tiles-small/ || die "doins failed"
+ newicon tiles-v1/tongE.xpm ${PN}.xpm
+ make_desktop_entry xmj Mah-Jong ${PN}
+ dodoc CHANGES ChangeLog *.txt
+ prepgamesdirs
+}