summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-12-07 22:33:57 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-12-07 22:33:57 +0000
commitadf9cd8e0ced59ff1dd70a0c8e5f8334202f63c3 (patch)
tree846595f35ae73d4f2e4ea9e81a00a28895423208 /games-board
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-adf9cd8e0ced59ff1dd70a0c8e5f8334202f63c3.tar.gz
gentoo-2-adf9cd8e0ced59ff1dd70a0c8e5f8334202f63c3.tar.bz2
gentoo-2-adf9cd8e0ced59ff1dd70a0c8e5f8334202f63c3.zip
Version bump. Bug #197935
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog7
-rw-r--r--games-board/crafty/crafty-21.6.ebuild81
-rw-r--r--games-board/crafty/files/digest-crafty-21.63
3 files changed, 90 insertions, 1 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index 8229f6d9217c..a9a75aabb864 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.21 2007/03/12 13:44:57 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.22 2007/12/07 22:33:56 tupone Exp $
+
+*crafty-21.6 (07 Dec 2007)
+
+ 07 Dec 2007; Tupone Alfredo <tupone@gentoo.org> +crafty-21.6.ebuild:
+ Version bump. Bug #197935 by Christos Gitsis
12 Mar 2007; Marius Mauch <genone@gentoo.org> crafty-20.13.ebuild,
crafty-20.14.ebuild:
diff --git a/games-board/crafty/crafty-21.6.ebuild b/games-board/crafty/crafty-21.6.ebuild
new file mode 100644
index 000000000000..f2dc99276ac6
--- /dev/null
+++ b/games-board/crafty/crafty-21.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-21.6.ebuild,v 1.1 2007/12/07 22:33:56 tupone Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="Bob Hyatt's strong chess engine"
+HOMEPAGE="ftp://ftp.cis.uab.edu/pub/hyatt/"
+SRC_URI="ftp://ftp.cis.uab.edu/pub/hyatt/source/${P}.zip"
+
+LICENSE="crafty"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="icc no-opts"
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ icc? ( >=dev-lang/icc-5.0 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/-o crafty/s/CC/CXX/' \
+ -e 's:CXFLAGS:CXXFLAGS:g' \
+ Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c \
+ || die "sed failed"
+}
+
+src_compile() {
+ local makeopts="target=LINUX"
+
+ if ! use no-opts ; then
+ if use icc ; then
+ makeopts="${makeopts} CC=icc CXX=gcc asm=X86.o"
+ append-flags -D_REENTRANT -tpp6 \
+ -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B -DFAST \
+ -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -O2 -fno-alias -fforce-mem \
+ -fomit-frame-pointer -fno-gcse -mpreferred-stack-boundary=2
+ else
+ if [[ "${CHOST}" == "i686-pc-linux-gnu" ]] \
+ || [[ "${CHOST}" == "i586-pc-linux-gnu" ]] ; then
+ append-flags -DCOMPACT_ATTACKS -DUSE_ATTACK_FUNCTIONS \
+ -DUSE_ASSEMBLY_A -DUSE_ASSEMBLY_B \
+ -DFAST -DSMP -DCPUS=4 -DCLONE -DDGT
+ append-flags -fno-gcse \
+ -fomit-frame-pointer -mpreferred-stack-boundary=2
+ makeopts="${makeopts} CC=gcc CXX=g++ asm=X86.o"
+ else
+ : # everything else :)
+ fi
+ fi
+ fi
+ append-flags -DPOSIX
+ emake ${makeopts} crafty-make LDFLAGS="${LDFLAGS} -lpthread" || die "build failed"
+}
+
+src_install() {
+ dogamesbin crafty || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins crafty.hlp || die "doins failed"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog
+ elog "Note: No books or tablebases have been installed. If you want them, just"
+ elog " download them from ${HOMEPAGE}."
+ elog " You will find documentation there too. In most cases you take now "
+ elog " your xboard compatible application, (xboard, eboard, knights) and "
+ elog " just play chess against computer opponent. Have fun."
+ elog
+}
diff --git a/games-board/crafty/files/digest-crafty-21.6 b/games-board/crafty/files/digest-crafty-21.6
new file mode 100644
index 000000000000..cb8c49934c9a
--- /dev/null
+++ b/games-board/crafty/files/digest-crafty-21.6
@@ -0,0 +1,3 @@
+MD5 3ba77a663e85e180c7d95fda1722449f crafty-21.6.zip 423100
+RMD160 d8fd129967638cbe614e7d3a90e9a4f53db93024 crafty-21.6.zip 423100
+SHA256 be5ec37938f7b741e5f3bded193fb6e30e0cb69f910202b7cc01f01846b42b56 crafty-21.6.zip 423100