summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-10 22:16:59 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-10 22:16:59 +0000
commitc821eae111796a3bcfa7ec96150e7b47035c4691 (patch)
treeb610d6baca58278a27be02b235633e25a86debfa /games-board
parentUse locks to avoid race conditions when merging (bug #449760). Use tar instea... (diff)
downloadgentoo-2-c821eae111796a3bcfa7ec96150e7b47035c4691.tar.gz
gentoo-2-c821eae111796a3bcfa7ec96150e7b47035c4691.tar.bz2
gentoo-2-c821eae111796a3bcfa7ec96150e7b47035c4691.zip
migrate to distutils-r1
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pysolfc/ChangeLog9
-rw-r--r--games-board/pysolfc/pysolfc-2.0-r1.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/games-board/pysolfc/ChangeLog b/games-board/pysolfc/ChangeLog
index 2f0394bdc8c0..dad4bec2a79c 100644
--- a/games-board/pysolfc/ChangeLog
+++ b/games-board/pysolfc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pysolfc
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/ChangeLog,v 1.5 2012/10/15 05:39:54 mr_bones_ Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/ChangeLog,v 1.6 2013/01/10 22:16:59 hasufell Exp $
+
+*pysolfc-2.0-r1 (10 Jan 2013)
+
+ 10 Jan 2013; Julian Ospald <hasufell@gentoo.org> +pysolfc-2.0-r1.ebuild:
+ migrate to distutils-r1
15 Oct 2012; Michael Sterrett <mr_bones_@gentoo.org> metadata.xml:
metadata fix (bug #438318)
diff --git a/games-board/pysolfc/pysolfc-2.0-r1.ebuild b/games-board/pysolfc/pysolfc-2.0-r1.ebuild
new file mode 100644
index 000000000000..add7e4b12387
--- /dev/null
+++ b/games-board/pysolfc/pysolfc-2.0-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pysolfc/pysolfc-2.0-r1.ebuild,v 1.1 2013/01/10 22:16:59 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_REQ_USE="tk"
+
+# inherit base explicitly to avoid random overrides on distutils-r1
+inherit base eutils python-r1 distutils-r1 games
+
+MY_PN=PySolFC
+SOL_URI="mirror://sourceforge/${PN}"
+
+DESCRIPTION="An exciting collection of more than 1000 solitaire card games"
+HOMEPAGE="http://pysolfc.sourceforge.net/"
+SRC_URI="${SOL_URI}/${MY_PN}-${PV}.tar.bz2
+ extra-cardsets? ( ${SOL_URI}/${MY_PN}-Cardsets-${PV}.tar.bz2 )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extra-cardsets minimal +sound"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+RDEPEND="sound? ( dev-python/pygame )
+ !minimal? ( dev-python/imaging[tk]
+ dev-tcltk/tktable )"
+
+python_prepare_all() {
+ sed -i \
+ -e "/pysol.desktop/d" \
+ -e "s:share/icons:share/pixmaps:" \
+ -e "s:data_dir =.*:data_dir = \'share/games/${PN}\':" \
+ setup.py || die
+
+ # avoid installing pysol.py into /usr/bin
+ sed -i \
+ -e '/scripts/d' \
+ setup.py || die
+}
+
+# Avoid running emake on shipped Makefile
+src_compile() { :; }
+
+python_install_all() {
+ exeinto "${GAMES_DATADIR}"/${PN}
+ doexe pysol.py
+ python_replicate_script "${ED}${GAMES_DATADIR}"/${PN}/pysol.py
+
+ games_make_wrapper ${PN} ./pysol.py "${GAMES_DATADIR}"/${PN}
+
+ make_desktop_entry ${PN} "PySol Fan Club Edition" pysol01
+
+ if use extra-cardsets; then
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r "${WORKDIR}"/${MY_PN}-Cardsets-${PV}/*
+ fi
+
+ doman docs/*.6
+ dohtml docs/*.html
+
+ dodoc AUTHORS README
+
+ docinto docs
+ dodoc docs/README*
+
+ prepgamesdirs
+}