summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-31 11:59:04 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-31 11:59:04 +0000
commitf7296134c1e0b569397f57fb826a9c4d699015cd (patch)
treec7fcfe820c8973957dc361268df4a017f9df57ac /games-board
parentVersion bump (bug #416627). (diff)
downloadgentoo-2-f7296134c1e0b569397f57fb826a9c4d699015cd.tar.gz
gentoo-2-f7296134c1e0b569397f57fb826a9c4d699015cd.tar.bz2
gentoo-2-f7296134c1e0b569397f57fb826a9c4d699015cd.zip
Version bump (bug #412083).
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pychess/ChangeLog7
-rw-r--r--games-board/pychess/pychess-0.10.1.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/games-board/pychess/ChangeLog b/games-board/pychess/ChangeLog
index e285ac3e213b..73c539330226 100644
--- a/games-board/pychess/ChangeLog
+++ b/games-board/pychess/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pychess
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/ChangeLog,v 1.14 2012/04/13 19:16:05 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/ChangeLog,v 1.15 2012/05/31 11:59:04 radhermit Exp $
+
+*pychess-0.10.1 (31 May 2012)
+
+ 31 May 2012; Tim Harder <radhermit@gentoo.org> +pychess-0.10.1.ebuild:
+ Version bump (bug #412083).
13 Apr 2012; Ulrich Müller <ulm@gentoo.org> pychess-0.10.ebuild:
Move EAPI assignment to top of ebuild, bug 411875.
diff --git a/games-board/pychess/pychess-0.10.1.ebuild b/games-board/pychess/pychess-0.10.1.ebuild
new file mode 100644
index 000000000000..b541332b6e7a
--- /dev/null
+++ b/games-board/pychess/pychess-0.10.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pychess/pychess-0.10.1.ebuild,v 1.1 2012/05/31 11:59:04 radhermit Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+inherit python games distutils
+
+DESCRIPTION="A chess client for Gnome"
+HOMEPAGE="http://pychess.googlepages.com/home"
+SRC_URI="http://pychess.googlecode.com/files/${P/_/}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+DEPEND="dev-python/librsvg-python
+ dev-python/pycairo
+ dev-python/pygobject:2
+ dev-python/pygtk
+ dev-python/pygtksourceview
+ dev-python/pysqlite
+ gstreamer? ( dev-python/gst-python )
+ dev-python/gconf-python
+ x11-themes/gnome-icon-theme"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P/_/}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+ games_pkg_setup
+}
+
+src_install() {
+ distutils_src_install --install-scripts="${GAMES_BINDIR}"
+ dodoc AUTHORS README
+ prepgamesdirs
+}