summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-22 00:06:14 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-22 00:06:14 +0000
commitef104531a1d30da6a5c1df9d8864a8979636247a (patch)
tree0c32ed5437290be1c594aac619536d472c9aca47 /games-emulation/advancemame
parentstabling fakeroot 1.1.5 on x86. (diff)
downloadgentoo-2-ef104531a1d30da6a5c1df9d8864a8979636247a.tar.gz
gentoo-2-ef104531a1d30da6a5c1df9d8864a8979636247a.tar.bz2
gentoo-2-ef104531a1d30da6a5c1df9d8864a8979636247a.zip
version bump
(Portage version: 2.0.51.19)
Diffstat (limited to 'games-emulation/advancemame')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest2
-rw-r--r--games-emulation/advancemame/advancemame-0.94.0.ebuild84
-rw-r--r--games-emulation/advancemame/files/0.94.0-pic.patch13
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.94.01
5 files changed, 107 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index c4b7b0cae275..b98dcb8142c9 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.25 2005/02/23 00:57:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.26 2005/03/22 00:06:14 mr_bones_ Exp $
+
+*advancemame-0.94.0 (21 Mar 2005)
+
+ 21 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.94.0-pic.patch, +advancemame-0.94.0.ebuild:
+ version bump
*advancemame-0.92.1 (22 Feb 2005)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index ea6aa67cce69..fa5eb86c73cf 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -5,6 +5,7 @@ MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
MD5 c47fa3e5e67db3de30c96197dbeb1f3f advancemame-0.88.0.ebuild 1991
MD5 62b15950728d12db8ccf2daa73b490a6 advancemame-0.89.0.ebuild 1990
MD5 54bd0b6abdb37ccac95cc5e61ccb04df advancemame-0.92.1.ebuild 1994
+MD5 54bd0b6abdb37ccac95cc5e61ccb04df advancemame-0.94.0.ebuild 1994
MD5 2612e9d2dbca377b7052486899a0b004 files/digest-advancemame-0.90.0 72
MD5 893791a430019a7eb1c0eaf15758a93f files/0.90.0-pic.patch 344
MD5 67836215b1438a2338c7f1ee054b9fb7 files/digest-advancemame-0.92.0 72
@@ -14,3 +15,4 @@ MD5 893791a430019a7eb1c0eaf15758a93f files/0.89.0-pic.patch 344
MD5 8aaeef301de9a34d24cfb74973b8ef9b files/digest-advancemame-0.89.0 72
MD5 ba36547c96ae664ea7d163c3cdb69858 files/digest-advancemame-0.92.1 72
MD5 893791a430019a7eb1c0eaf15758a93f files/0.92.1-pic.patch 344
+MD5 0727e29d4a4d201dc55062d7e2c740e7 files/digest-advancemame-0.94.0 72
diff --git a/games-emulation/advancemame/advancemame-0.94.0.ebuild b/games-emulation/advancemame/advancemame-0.94.0.ebuild
new file mode 100644
index 000000000000..148c3fc7adae
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.94.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.94.0.ebuild,v 1.1 2005/03/22 00:06:14 mr_bones_ Exp $
+
+inherit games eutils
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-pic.patch" #74899
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/0.94.0-pic.patch b/games-emulation/advancemame/files/0.94.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemame/files/0.94.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.94.0 b/games-emulation/advancemame/files/digest-advancemame-0.94.0
new file mode 100644
index 000000000000..1279a5d3de8f
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.94.0
@@ -0,0 +1 @@
+MD5 9081296d33bfeb69552b12d56e346bcb advancemame-0.94.0.tar.gz 14574108