summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-09-29 06:10:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-09-29 06:10:57 +0000
commit3a693df559c966eed3bcd64c706d12ccd48b7011 (patch)
tree9593c7aa70d4f330e10967c9e5d510ca317bc7c0 /games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
parentdon't use emake for install; add error message (diff)
downloadgentoo-2-3a693df559c966eed3bcd64c706d12ccd48b7011.tar.gz
gentoo-2-3a693df559c966eed3bcd64c706d12ccd48b7011.tar.bz2
gentoo-2-3a693df559c966eed3bcd64c706d12ccd48b7011.zip
use games eclass; use use_with; added more docs
Diffstat (limited to 'games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild')
-rw-r--r--games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild31
1 files changed, 17 insertions, 14 deletions
diff --git a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
index 61eda7e16a98..3e90584b8a98 100644
--- a/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
+++ b/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild
@@ -1,29 +1,32 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.1 2003/09/09 16:26:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dgen-sdl/dgen-sdl-1.23.ebuild,v 1.2 2003/09/29 06:10:55 mr_bones_ Exp $
-DESCRIPTION="DGen/SDL is a Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
+inherit games
+
+DESCRIPTION="A Linux/SDL-Port of the famous DGen MegaDrive/Genesis-Emulator"
HOMEPAGE="http://www.pknet.com/~joe/dgen-sdl.html"
SRC_URI="http://www.pknet.com/~joe/${P}.tar.gz"
-SLOT="0"
-KEYWORDS="x86"
LICENSE="dgen-sdl"
+KEYWORDS="x86"
+SLOT="0"
+
IUSE="X mmx opengl"
-DEPEND="media-libs/libsdl X? virtual/x11 opengl? virtual/opengl"
-RDEPEND="${DEPEND} dev-lang/nasm"
+DEPEND="media-libs/libsdl
+ X? virtual/x11
+ opengl? virtual/opengl"
+RDEPEND="${DEPEND}
+ dev-lang/nasm"
src_compile() {
- local myconf=""
- use opengl || myconf="${myconf} --without-opengl"
- use X && myconf="${myconf} --with-x"
- use mmx || myconf="${myconf} --without-mmx"
-
- econf ${myconf}
- emake || die
+ egamesconf `use_with opengl` `use_with X x` `use_with mmx` || die
+ emake || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc AUTHORS ChangeLog README sample.dgenrc
+ prepgamesdirs
}