summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-11-09 22:21:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-11-09 22:21:27 +0000
commit449af27d832082642db60f53b95ce179bf643b2e (patch)
tree578dd4e5817232f32a89b3da6680f94f431f9d97 /games-emulation/dosbox
parentenable user patching (diff)
downloadgentoo-2-449af27d832082642db60f53b95ce179bf643b2e.tar.gz
gentoo-2-449af27d832082642db60f53b95ce179bf643b2e.tar.bz2
gentoo-2-449af27d832082642db60f53b95ce179bf643b2e.zip
add live svn ebuild to replace dosbox-cvs (bug #292468)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/ChangeLog7
-rw-r--r--games-emulation/dosbox/dosbox-9999.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/games-emulation/dosbox/ChangeLog b/games-emulation/dosbox/ChangeLog
index 5742e14f5398..2e3640f2162a 100644
--- a/games-emulation/dosbox/ChangeLog
+++ b/games-emulation/dosbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/dosbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.47 2009/08/18 22:21:59 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.48 2009/11/09 22:21:27 mr_bones_ Exp $
+
+*dosbox-9999 (09 Nov 2009)
+
+ 09 Nov 2009; Michael Sterrett <mr_bones_@gentoo.org> +dosbox-9999.ebuild:
+ add live svn ebuild to replace dosbox-cvs (bug #292468)
18 Aug 2009; Christian Faulhammer <fauli@gentoo.org> dosbox-0.73.ebuild:
stable x86, bug 279864
diff --git a/games-emulation/dosbox/dosbox-9999.ebuild b/games-emulation/dosbox/dosbox-9999.ebuild
new file mode 100644
index 000000000000..30fb11d497d9
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-9999.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-9999.ebuild,v 1.1 2009/11/09 22:21:27 mr_bones_ Exp $
+
+EAPI=2
+ESVN_REPO_URI="https://dosbox.svn.sourceforge.net/svnroot/dosbox/dosbox/trunk"
+inherit autotools eutils subversion games
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="alsa debug hardened opengl"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/opengl )
+ debug? ( sys-libs/ncurses )
+ media-libs/libpng
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_prepare() {
+ subversion_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+ prepgamesdirs
+}