summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-05-16 20:34:25 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-05-16 20:34:25 +0000
commitbd8f5d666a9d89117188d34016d3eff0fd09801a (patch)
tree1853edc8f44dec96abd08e78ecc35ebbfaa62fc1 /games-emulation/dosbox
parentStable on amd64 wrt bug #302033 (diff)
downloadgentoo-2-bd8f5d666a9d89117188d34016d3eff0fd09801a.tar.gz
gentoo-2-bd8f5d666a9d89117188d34016d3eff0fd09801a.tar.bz2
gentoo-2-bd8f5d666a9d89117188d34016d3eff0fd09801a.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/ChangeLog7
-rw-r--r--games-emulation/dosbox/dosbox-0.74.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/games-emulation/dosbox/ChangeLog b/games-emulation/dosbox/ChangeLog
index 9044ed69561a..ba975d820ca1 100644
--- a/games-emulation/dosbox/ChangeLog
+++ b/games-emulation/dosbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/dosbox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.49 2010/03/10 11:08:52 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.50 2010/05/16 20:34:25 mr_bones_ Exp $
+
+*dosbox-0.74 (16 May 2010)
+
+ 16 May 2010; Michael Sterrett <mr_bones_@gentoo.org> +dosbox-0.74.ebuild:
+ version bump
10 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> dosbox-0.73.ebuild,
+files/dosbox-0.73-AC_CANONICAL_BUILD_and_libpng14.patch:
diff --git a/games-emulation/dosbox/dosbox-0.74.ebuild b/games-emulation/dosbox/dosbox-0.74.ebuild
new file mode 100644
index 000000000000..319783d0d406
--- /dev/null
+++ b/games-emulation/dosbox/dosbox-0.74.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.74.ebuild,v 1.1 2010/05/16 20:34:25 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="DOS emulator"
+HOMEPAGE="http://dosbox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/dosbox/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa debug hardened opengl"
+
+DEPEND="alsa? ( media-libs/alsa-lib )
+ opengl? ( virtual/opengl )
+ debug? ( sys-libs/ncurses )
+ media-libs/libpng
+ media-libs/libsdl[joystick,video]
+ media-libs/sdl-net
+ media-libs/sdl-sound"
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable alsa alsa-midi) \
+ $(use_enable !hardened dynamic-x86) \
+ $(use_enable debug) \
+ $(use_enable opengl)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS
+ make_desktop_entry dosbox DOSBox /usr/share/pixmaps/dosbox.ico
+ doicon src/dosbox.ico
+ prepgamesdirs
+}