summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-03-17 18:03:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-03-17 18:03:15 +0000
commit0b2f4cf6328836eb48a97283ca99a47d7355883c (patch)
tree14d052f6657e74004ef347c343fd8a1f82704322 /games-emulation/generator
parentAdded a patch to use newer liborigin, from Debian (diff)
downloadgentoo-2-0b2f4cf6328836eb48a97283ca99a47d7355883c.tar.gz
gentoo-2-0b2f4cf6328836eb48a97283ca99a47d7355883c.tar.bz2
gentoo-2-0b2f4cf6328836eb48a97283ca99a47d7355883c.zip
disable gtk+-1 interface since it's unsupported and generator otherwise fails to build without gtk+-1 available on the system (bug #206373)
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-emulation/generator')
-rw-r--r--games-emulation/generator/ChangeLog7
-rw-r--r--games-emulation/generator/files/generator-0.35_p3-configure.patch41
-rw-r--r--games-emulation/generator/generator-0.35_p3.ebuild15
3 files changed, 52 insertions, 11 deletions
diff --git a/games-emulation/generator/ChangeLog b/games-emulation/generator/ChangeLog
index b4d8ef15343b..8c2cce717719 100644
--- a/games-emulation/generator/ChangeLog
+++ b/games-emulation/generator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/generator
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.20 2008/03/06 21:53:36 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/ChangeLog,v 1.21 2008/03/17 18:03:15 mr_bones_ Exp $
+
+ 17 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ files/generator-0.35_p3-configure.patch, generator-0.35_p3.ebuild:
+ disable gtk+-1 interface since it's unsupported and generator otherwise fails
+ to build without gtk+-1 available on the system (bug #206373)
06 Mar 2008; Chris Gianelloni <wolf31o2@gentoo.org> generator-0.35.ebuild:
QA cleanup: Fix quoting.
diff --git a/games-emulation/generator/files/generator-0.35_p3-configure.patch b/games-emulation/generator/files/generator-0.35_p3-configure.patch
index cc4046c7e62b..72ed087bd296 100644
--- a/games-emulation/generator/files/generator-0.35_p3-configure.patch
+++ b/games-emulation/generator/files/generator-0.35_p3-configure.patch
@@ -1,6 +1,23 @@
---- configure.ac.orig 2007-04-11 16:28:09.000000000 -0400
-+++ configure.ac 2007-04-11 16:29:07.000000000 -0400
-@@ -202,50 +202,6 @@
+--- configure.ac.original 2008-03-17 13:07:48.000000000 -0400
++++ configure.ac 2008-03-17 13:08:03.000000000 -0400
+@@ -28,15 +28,12 @@
+ AC_ARG_WITH(tcltk,
+ AS_HELP_STRING(--with-tcltk,Create tcltk version),
+ MY_PROG="generator-tcltk")
+- AC_ARG_WITH(gtk,
+- AS_HELP_STRING(--with-gtk,Create gtk version),
+- MY_PROG="generator-gtk")
+ AC_ARG_WITH(sdl,
+ AS_HELP_STRING(--with-sdl,Create SDL version),
+ [MY_PROG="generator-sdl"; USE_SDL_AUDIO=yes])
+ if [[ "x$MY_PROG" = "x" ]]; then
+ AC_MSG_ERROR(You must select a user interface type:
+- svgalib allegro tcltk gtk sdl)
++ svgalib allegro tcltk sdl)
+ fi
+ if [[ "x$MY_PROG" = "xgenerator-allegro" ]]; then
+ AC_DEFINE(ALLEGRO, 1, [Allegro version])
+@@ -202,50 +199,6 @@
CFLAGS="$CFLAGS -Wstrict-prototypes -Wunused"
fi
fi
@@ -51,7 +68,23 @@
AC_CHECK_LIB(jpeg, jpeg_start_compress,
[ MY_LIBS="-ljpeg $MY_LIBS"; AC_DEFINE(JPEG, 1, [JPEG features]) ])
-@@ -305,6 +261,7 @@
+@@ -272,14 +225,7 @@
+
+ AC_PATH_XTRA
+
+- if [[ "x$MY_PROG" = "xgenerator-gtk" ]]; then
+- MY_SUBDIRS="glade gtkopts $MY_SUBDIRS"
+- AM_PATH_GTK(1.2.10,,AC_MSG_ERROR(Generator needs gtk 1.2.10 or later))
+- AM_PATH_SDL(1.2.6,,AC_MSG_ERROR(Generator needs sdk 1.2.6 or later))
+-
+- MY_LIBS="$MY_LIBS $X_PRE_LIBS $X_LIBS $X_EXTRA_LIBS"
+- CFLAGS="$CFLAGS $X_CFLAGS"
+- elif [[ "x$MY_PROG" = "xgenerator-sdl" ]]; then
++ if [[ "x$MY_PROG" = "xgenerator-sdl" ]]; then
+ MY_SUBDIRS="gtkopts $MY_SUBDIRS"
+ AM_PATH_SDL(1.2.6,,AC_MSG_ERROR(Generator needs sdk 1.2.6 or later))
+
+@@ -305,6 +251,7 @@
AC_CHECK_SIZEOF(unsigned long, 4)
AC_CHECK_SIZEOF(unsigned long long, 8)
AC_CHECK_HEADERS(sys/param.h)
diff --git a/games-emulation/generator/generator-0.35_p3.ebuild b/games-emulation/generator/generator-0.35_p3.ebuild
index 1d8baffa371b..86ce0cc91e82 100644
--- a/games-emulation/generator/generator-0.35_p3.ebuild
+++ b/games-emulation/generator/generator-0.35_p3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35_p3.ebuild,v 1.3 2007/07/30 21:33:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/generator/generator-0.35_p3.ebuild,v 1.4 2008/03/17 18:03:15 mr_bones_ Exp $
inherit autotools eutils toolchain-funcs games
@@ -12,11 +12,10 @@ SRC_URI="http://www.ghostwhitecrab.com/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="gtk sdlaudio svga"
+IUSE="sdlaudio svga"
RDEPEND="media-libs/jpeg
media-libs/libsdl
- gtk? ( =x11-libs/gtk+-1.2* )
svga? ( media-libs/svgalib )"
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
@@ -42,10 +41,14 @@ src_unpack() {
-e 's/USE32//' \
raze/raze.asm.in \
|| die 'sed failed'
+ sed -i \
+ -e 's/@GTK_CFLAGS@//g' \
+ main/Makefile.am \
+ || die "sed failed"
eautoreconf
}
-# builds SDL by default since otherwise -svga -gtk builds nothing
+# builds SDL by default since otherwise -svga builds nothing
src_compile() {
local myconf mygui myguis
@@ -54,7 +57,6 @@ src_compile() {
|| myconf="--with-cmz80"
myguis="sdl"
- use gtk && myguis="${myguis} gtk"
use svga && myguis="${myguis} svgalib"
for mygui in ${myguis}; do
@@ -62,6 +64,7 @@ src_compile() {
egamesconf \
${myconf} \
--with-${mygui} \
+ --without-gtk \
--without-tcltk \
--with-gcc=$(gcc-major-version) \
$(use_with sdlaudio sdl-audio) \