summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-10-31 23:46:39 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-10-31 23:46:39 +0000
commit2c0f195b3f51d0bfcc24505dc1f198a836338fd4 (patch)
tree32dfaa9ed59e0b911850958134155da2ce657807 /games-emulation/gngb/gngb-20060309.ebuild
parentVersion bumb, bug #197525. (diff)
downloadgentoo-2-2c0f195b3f51d0bfcc24505dc1f198a836338fd4.tar.gz
gentoo-2-2c0f195b3f51d0bfcc24505dc1f198a836338fd4.tar.bz2
gentoo-2-2c0f195b3f51d0bfcc24505dc1f198a836338fd4.zip
Version bump to 20060309
(Portage version: 2.1.3.16)
Diffstat (limited to 'games-emulation/gngb/gngb-20060309.ebuild')
-rw-r--r--games-emulation/gngb/gngb-20060309.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/games-emulation/gngb/gngb-20060309.ebuild b/games-emulation/gngb/gngb-20060309.ebuild
new file mode 100644
index 000000000000..f51192e0d85c
--- /dev/null
+++ b/games-emulation/gngb/gngb-20060309.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/gngb-20060309.ebuild,v 1.1 2007/10/31 23:46:39 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="Gameboy / Gameboy Color emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngb/"
+SRC_URI="http://m.peponas.free.fr/gngb/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib
+ app-arch/bzip2
+ opengl? ( virtual/opengl )"
+
+src_compile() {
+ egamesconf $(use_with opengl gl) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+ prepgamesdirs
+}