summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-29 04:19:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-29 04:19:01 +0000
commit8647288fb0f473063d4e5ce700d85c42f9341aac (patch)
tree207da5dac0a4ab7face452a19dcd0e8d0958cf3b /games-emulation/gnuboy/gnuboy-1.0.3.ebuild
parentmarking 1.10-r3 stable (x86) (diff)
downloadgentoo-2-8647288fb0f473063d4e5ce700d85c42f9341aac.tar.gz
gentoo-2-8647288fb0f473063d4e5ce700d85c42f9341aac.tar.bz2
gentoo-2-8647288fb0f473063d4e5ce700d85c42f9341aac.zip
more choices for gui - patch from James Rowe via bug #99983
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/gnuboy/gnuboy-1.0.3.ebuild')
-rw-r--r--games-emulation/gnuboy/gnuboy-1.0.3.ebuild43
1 files changed, 36 insertions, 7 deletions
diff --git a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
index fb0629957d31..6d195942ffd3 100644
--- a/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
+++ b/games-emulation/gnuboy/gnuboy-1.0.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.7 2004/06/24 22:28:21 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gnuboy/gnuboy-1.0.3.ebuild,v 1.8 2005/08/29 04:19:01 mr_bones_ Exp $
+
+inherit games
DESCRIPTION="Gameboy emulator with multiple renderers"
HOMEPAGE="http://gnuboy.unix-fu.org/"
@@ -8,12 +10,39 @@ SRC_URI="http://gnuboy.unix-fu.org/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc amd64"
-IUSE=""
+KEYWORDS="amd64 ppc x86"
+IUSE="X fbcon sdl svga"
+
+DEPEND="X? ( virtual/x11 )
+ sdl? ( media-libs/libsdl )
+ svga? ( media-libs/svgalib )
+ !X? ( !svga ( !fbcon ( media-libs/libsdl ) ) )"
+
+src_compile() {
+ local myconf
-RDEPEND="media-libs/libsdl"
+ if ! use X && ! use svga && ! use fbcon; then
+ myconf="--with-sdl"
+ fi
+
+ egamesconf \
+ $(use_with X x) \
+ $(use_with fbcon fb) \
+ $(use_with sdl) \
+ $(use_with svga svgalib) \
+ $(use_enable x86 asm) \
+ ${myconf} \
+ --disable-arch \
+ --disable-optimize
+ emake || die "emake failed"
+}
src_install() {
- dodoc README docs/CHANGES docs/CONFIG docs/CREDITS docs/FAQ docs/HACKING docs/WHATSNEW
- dobin fbgnuboy sdlgnuboy sgnuboy xgnuboy || die
+ for f in fbgnuboy sdlgnuboy sgnuboy xgnuboy
+ do
+ if [[ -f $f ]] ; then
+ dogamesbin $f || die "dogamesbin failed"
+ fi
+ done
+ dodoc README docs/{CHANGES,CONFIG,CREDITS,FAQ,HACKING,WHATSNEW}
}