summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-12-25 17:42:29 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-12-25 17:42:29 +0000
commit350f302ae866ee2e29fae0b087580c81a3eec937 (patch)
tree48ec1cc04e05089df09462601315277cbf201e03 /games-emulation/mednafen
parentStable on IA64. (diff)
downloadgentoo-2-350f302ae866ee2e29fae0b087580c81a3eec937.tar.gz
gentoo-2-350f302ae866ee2e29fae0b087580c81a3eec937.tar.bz2
gentoo-2-350f302ae866ee2e29fae0b087580c81a3eec937.zip
debug USE flag for disabling the debugger
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'games-emulation/mednafen')
-rw-r--r--games-emulation/mednafen/mednafen-0.7.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/games-emulation/mednafen/mednafen-0.7.1.ebuild b/games-emulation/mednafen/mednafen-0.7.1.ebuild
index e0ef75176c90..2a8cc861794b 100644
--- a/games-emulation/mednafen/mednafen-0.7.1.ebuild
+++ b/games-emulation/mednafen/mednafen-0.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.7.1.ebuild,v 1.1 2006/12/25 11:41:30 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.7.1.ebuild,v 1.2 2006/12/25 17:42:29 nyhm Exp $
inherit games
@@ -11,12 +11,12 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="alsa cjk nls"
+IUSE="alsa cjk debug nls"
RDEPEND="virtual/opengl
media-libs/libsndfile
dev-libs/libcdio
- >=media-libs/libsdl-1.2.0
+ media-libs/libsdl
media-libs/sdl-net
alsa? ( media-libs/alsa-lib )
nls? ( virtual/libintl )"
@@ -33,7 +33,9 @@ src_unpack() {
-e 's:$(datadir)/locale:/usr/share/locale:' \
-e 's:$(localedir):/usr/share/locale:' \
$(find . -name 'Makefile.in*') \
- || die "sed failed"
+ || die "sed Makefile.in failed"
+ sed -i '/-fomit-frame/d' configure \
+ || die "sed configure failed"
}
src_compile() {
@@ -43,6 +45,7 @@ src_compile() {
--disable-dependency-tracking \
$(use_enable alsa) \
$(use_enable cjk cjk-fonts) \
+ $(use_enable debug debugger) \
$(use_enable nls) \
|| die
emake || die "emake failed"