summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-01-31 07:13:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-01-31 07:13:02 +0000
commitab771c43c294ebf0fd2cdf91103f3608f1524dfc (patch)
tree7b3ec4e313b193681caf439b64c2394cbe64aef8 /games-emulation/mupen64-blight-tr64gl
parentclean old ebuilds (diff)
downloadgentoo-2-ab771c43c294ebf0fd2cdf91103f3608f1524dfc.tar.gz
gentoo-2-ab771c43c294ebf0fd2cdf91103f3608f1524dfc.tar.bz2
gentoo-2-ab771c43c294ebf0fd2cdf91103f3608f1524dfc.zip
add missing src_unpack function (bug #79960)
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-emulation/mupen64-blight-tr64gl')
-rw-r--r--games-emulation/mupen64-blight-tr64gl/ChangeLog8
-rw-r--r--games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild8
2 files changed, 13 insertions, 3 deletions
diff --git a/games-emulation/mupen64-blight-tr64gl/ChangeLog b/games-emulation/mupen64-blight-tr64gl/ChangeLog
index 95bc5894cf33..3777570a545b 100644
--- a/games-emulation/mupen64-blight-tr64gl/ChangeLog
+++ b/games-emulation/mupen64-blight-tr64gl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/mupen64-blight-tr64gl
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-blight-tr64gl/ChangeLog,v 1.4 2005/01/23 02:15:23 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-blight-tr64gl/ChangeLog,v 1.5 2005/01/31 07:13:02 mr_bones_ Exp $
+
+*mupen64-blight-tr64gl-0.8.7_pre1 (31 Jan 2005)
+
+ 31 Jan 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ mupen64-blight-tr64gl-0.8.7_pre1.ebuild:
+ add missing src_unpack function (bug #79960)
22 Jan 2005; Daniel Goller <morfic@gentoo.org> :
Bump to new version available
diff --git a/games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild b/games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild
index d74c6e76ec85..b38bb5ba9390 100644
--- a/games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild
+++ b/games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild,v 1.1 2005/01/23 02:15:23 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-blight-tr64gl/mupen64-blight-tr64gl-0.8.7_pre1.ebuild,v 1.2 2005/01/31 07:13:02 mr_bones_ Exp $
inherit games
@@ -18,7 +18,11 @@ RDEPEND="media-libs/libsdl"
S="${WORKDIR}"
-src_install () {
+src_unpack() {
+ cp "${DISTDIR}/${MY_P}.so" "${WORKDIR}" || die "cp failed"
+}
+
+src_install() {
exeinto "${GAMES_LIBDIR}/mupen64/plugins"
doexe ${MY_P}.so || die "doexe failed"
prepgamesdirs