summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-04 04:49:29 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-04 04:49:29 +0000
commitde3d394a870a33a487446c7208a0cf4d2f93af8b (patch)
tree5d865686a5a3ee32e6bff4dfbc0fc3294121734e /games-emulation/pcsx2/pcsx2-0.8.1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-de3d394a870a33a487446c7208a0cf4d2f93af8b.tar.gz
gentoo-2-de3d394a870a33a487446c7208a0cf4d2f93af8b.tar.bz2
gentoo-2-de3d394a870a33a487446c7208a0cf4d2f93af8b.zip
Don't hardcode the games paths in the wrapper script; version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-0.8.1.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-0.8.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-emulation/pcsx2/pcsx2-0.8.1.ebuild b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
new file mode 100644
index 000000000000..d048c1739279
--- /dev/null
+++ b/games-emulation/pcsx2/pcsx2-0.8.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx2/pcsx2-0.8.1.ebuild,v 1.1 2005/08/04 04:49:29 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Playstation2 emulator"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.8release/${P}src.7z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/x11
+ =x11-libs/gtk+-1*
+ || (
+ >=games-emulation/ps2emu-cddvdlinuz-0.3-r1
+ >=games-emulation/ps2emu-cdvdiso-0.3
+ )
+ >=games-emulation/ps2emu-gssoft-0.61
+ >=games-emulation/ps2emu-padxwin-0.5
+ >=games-emulation/ps2emu-spu2null-0.21
+ >=games-emulation/ps2emu-dev9null-0.1"
+DEPEND="${RDEPEND}
+ app-arch/p7zip"
+
+S=${WORKDIR}/${P}src
+
+src_unpack() {
+ cd "${WORKDIR}"
+ 7z x "${DISTDIR}/${P}src.7z" || die "unpack failed"
+ cd "${S}"
+ sed -i \
+ -e "/^CC/d" \
+ Linux/Makefile \
+ || die "sed failed"
+ sed -i \
+ -e "/non_linear_quantizer_scale/s/^/extern /" \
+ IPU/Mpeg.h \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake -C Linux OPTIMIZE="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ newgamesbin Linux/pcsx2 pcsx2.bin || die "newgamesbin failed"
+ dogamesbin "${FILESDIR}/pcsx2" || die "dogamesbin failed"
+ sed -i \
+ -e "s:GAMES_BINDIR:${GAMES_BINDIR}:" \
+ -e "s:GAMES_LIBDIR:${GAMES_LIBDIR}:" \
+ "${D}/${GAMES_BINDIR}/pcsx2" \
+ || die "sed failed"
+ dodoc Docs/*.txt
+ prepgamesdirs
+}