summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-07 07:20:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-07 07:20:16 +0000
commit591ec120ff3606e11d47d7320a11c93229285274 (patch)
tree0c3d441ff706fa6d0dd095dd6a5c11a8f10012e2 /games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild
parentVersion bump and clean up amd64 support. (diff)
downloadgentoo-2-591ec120ff3606e11d47d7320a11c93229285274.tar.gz
gentoo-2-591ec120ff3606e11d47d7320a11c93229285274.tar.bz2
gentoo-2-591ec120ff3606e11d47d7320a11c93229285274.zip
Version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild')
-rw-r--r--games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild
new file mode 100644
index 000000000000..a9c01bc5646c
--- /dev/null
+++ b/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cdvdiso/ps2emu-cdvdiso-0.5.ebuild,v 1.1 2005/08/07 07:20:16 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 CD/DVD iso plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.8release/CDVDiso${PV//.}.rar"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-1*"
+DEPEND="${RDEPEND}
+ app-arch/unrar"
+
+S=${WORKDIR}/CDVDiso${PV//.}
+
+src_unpack() {
+ unrar x -idq "${DISTDIR}"/${A}
+ cd "${S}"
+ sed -i 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' src/Linux/Makefile || die
+}
+
+src_compile() {
+ cd src/Linux
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd src/Linux
+ exeinto "${GAMES_LIBDIR}"/ps2emu/plugins
+ newexe libCDVDiso.so libCDVDiso-${PV}.so || die
+ exeinto "${GAMES_LIBDIR}"/ps2emu/cfg
+ doexe cfgCDVDiso || die
+ prepgamesdirs
+}