summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-07 04:53:49 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-07 04:53:49 +0000
commitec748e1843aa0ad209a33fb2d0ea177414d3b69e (patch)
treea14c14f392c085e42e29c2377efa04aab7e517af /games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.6.1.ebuild
parentVersion bump #65374. (diff)
downloadgentoo-2-ec748e1843aa0ad209a33fb2d0ea177414d3b69e.tar.gz
gentoo-2-ec748e1843aa0ad209a33fb2d0ea177414d3b69e.tar.bz2
gentoo-2-ec748e1843aa0ad209a33fb2d0ea177414d3b69e.zip
rename version
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.6.1.ebuild')
-rw-r--r--games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.6.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.6.1.ebuild b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.6.1.ebuild
new file mode 100644
index 000000000000..e3cb498f336a
--- /dev/null
+++ b/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-gssoft/ps2emu-gssoft-0.6.1.ebuild,v 1.1 2005/08/07 04:53:49 vapier Exp $
+
+inherit games
+
+MY_PV=0.61
+DESCRIPTION="PSEmu2 GPU plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.5release/GSsoft-${MY_PV}.tgz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+DEPEND="virtual/opengl
+ virtual/x11
+ =x11-libs/gtk+-1*"
+
+S=${WORKDIR}/GSsoft
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:-O3 -fomit-frame-pointer:$(OPTFLAGS):' ${S}/Src/Linux/Makefile
+}
+
+src_compile() {
+ cd Src/Linux
+ emake OPTFLAGS="${CFLAGS}" || die "building X"
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ newexe Src/Linux/libGSsoftx.so libGSsoftx-${MY_PV}.so
+ prepgamesdirs
+}