summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-09 16:28:07 +0000
commitae044aeba549da343d278a26bb72bac844e5a5e4 (patch)
treeb16ea879113ef2bd09bb78bb00e8338b088d3afb /games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
parentNew package - rename. (diff)
downloadgentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.gz
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.tar.bz2
gentoo-2-ae044aeba549da343d278a26bb72bac844e5a5e4.zip
welcome to games-emulation
Diffstat (limited to 'games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild')
-rw-r--r--games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild b/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
new file mode 100644
index 000000000000..ab59dd42cf7e
--- /dev/null
+++ b/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/psemu-cdriso/psemu-cdriso-1.4.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="PSEmu plugin to read CD-images"
+HOMEPAGE="http://www.pcsx.net/"
+SRC_URI="http://linuzappz.pcsx.net/downloads/cdriso-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="sys-libs/zlib
+ sys-apps/bzip2
+ =x11-libs/gtk+-1*
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/cdriso
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-makefile-cflags.patch
+}
+
+src_compile() {
+ cd src/Linux
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ cd src/Linux
+ exeinto ${GAMES_LIBDIR}/psemu/plugins
+ doexe libcdriso-*
+ exeinto ${GAMES_LIBDIR}/psemu/cfg
+ doexe cfgCdrIso
+ prepgamesdirs
+}
+