summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-08 08:25:02 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-08 08:25:02 +0000
commitcd8212bd3cdba89185ff2d4c90eea144e112d061 (patch)
tree7a54d2fad21536b7dc1c382f89e20bd982cad772 /games-emulation/raine
parentversion bump, fixes bug #338621 (diff)
downloadgentoo-2-cd8212bd3cdba89185ff2d4c90eea144e112d061.tar.gz
gentoo-2-cd8212bd3cdba89185ff2d4c90eea144e112d061.tar.bz2
gentoo-2-cd8212bd3cdba89185ff2d4c90eea144e112d061.zip
Respect LDFLAGS. Bug #337107
(Portage version: 2.1.9.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation/raine')
-rw-r--r--games-emulation/raine/ChangeLog6
-rw-r--r--games-emulation/raine/files/raine-0.51.8-ldflags.patch11
-rw-r--r--games-emulation/raine/raine-0.51.8.ebuild4
3 files changed, 19 insertions, 2 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index d245ba3c838a..834e6d0d36cf 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/raine
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.25 2010/05/11 13:46:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.26 2010/10/08 08:25:02 tupone Exp $
+
+ 08 Oct 2010; Tupone Alfredo <tupone@gentoo.org> raine-0.51.8.ebuild,
+ +files/raine-0.51.8-ldflags.patch:
+ Respect LDFLAGS. Bug #337107 by flameeyes@gentoo.org
11 May 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> raine-0.51.8.ebuild:
x86 stable wrt bug #318083
diff --git a/games-emulation/raine/files/raine-0.51.8-ldflags.patch b/games-emulation/raine/files/raine-0.51.8-ldflags.patch
new file mode 100644
index 000000000000..f011cd6a1e5c
--- /dev/null
+++ b/games-emulation/raine/files/raine-0.51.8-ldflags.patch
@@ -0,0 +1,11 @@
+--- makefile.old 2010-10-08 10:04:46.000000000 +0200
++++ makefile 2010-10-08 10:05:25.000000000 +0200
+@@ -995,7 +995,7 @@
+ else
+ @echo Linking Raine...
+ endif
+- $(LDV) $(LFLAGS) -g -Wall -Wno-write-strings -o $(RAINE_EXE) $(OBJS) $(LIBS) -lstdc++
++ $(LDV) $(LDFLAGS) $(LFLAGS) -g -Wall -Wno-write-strings -o $(RAINE_EXE) $(OBJS) $(LIBS) -lstdc++
+
+ converter: source/bonus/converter.c
+ $(CCV) $(CFLAGS) -c $< -o $(OBJDIR)/converter.o
diff --git a/games-emulation/raine/raine-0.51.8.ebuild b/games-emulation/raine/raine-0.51.8.ebuild
index 646e14ae5d3c..9fd718e80dff 100644
--- a/games-emulation/raine/raine-0.51.8.ebuild
+++ b/games-emulation/raine/raine-0.51.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.51.8.ebuild,v 1.2 2010/05/11 13:46:53 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.51.8.ebuild,v 1.3 2010/10/08 08:25:02 tupone Exp $
EAPI=2
inherit eutils games
@@ -34,6 +34,7 @@ src_prepare() {
-e "/mandir/s:=.*:=\$(DESTDIR)/usr/share/man/man6:" \
makefile \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-ldflags.patch
}
src_compile() {
@@ -44,6 +45,7 @@ src_compile() {
|| myopts="${myopts} STATIC="
emake \
_MARCH="${CFLAGS}" \
+ VERBOSE=1 \
${myopts} || die "emake failed"
}