summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-28 21:17:10 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-28 21:17:10 +0000
commit12d20ec73d81067709c033270f38337698f7b3c0 (patch)
tree70d005313e45c3fd8834888cd209c69267fd9f46 /games-emulation/snes9x/files
parentMarked x86 stable (diff)
downloadgentoo-2-12d20ec73d81067709c033270f38337698f7b3c0.tar.gz
gentoo-2-12d20ec73d81067709c033270f38337698f7b3c0.tar.bz2
gentoo-2-12d20ec73d81067709c033270f38337698f7b3c0.zip
Add dev support for building for native amd64 #104049.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/snes9x/files')
-rw-r--r--games-emulation/snes9x/files/snes9x-1.43-porting.patch81
1 files changed, 81 insertions, 0 deletions
diff --git a/games-emulation/snes9x/files/snes9x-1.43-porting.patch b/games-emulation/snes9x/files/snes9x-1.43-porting.patch
new file mode 100644
index 000000000000..33d03bbc46e5
--- /dev/null
+++ b/games-emulation/snes9x/files/snes9x-1.43-porting.patch
@@ -0,0 +1,81 @@
+http://www.snes9x.com/phpbb2/viewtopic.php?p=12712
+http://bugs.gentoo.org/104049
+
+--- snes9x/configure.in
++++ snes9x/configure.in
+@@ -585,6 +585,19 @@
+ SYSDEFINES="$SYSDEFINES"' -DHAVE_SYS_IOCTL_H'
+ ])
+
++AC_CHECK_HEADER(endian.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_ENDIAN_H'
++])
++AC_CHECK_HEADER(sys/endian.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_SYS_ENDIAN_H'
++])
++AC_CHECK_HEADER(machine/endian.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_MACHINE_ENDIAN_H'
++])
++AC_CHECK_HEADER(sys/isa_defs.h, [
++ SYSDEFINES="$SYSDEFINES"' -DHAVE_SYS_ISA_DEFS_H'
++])
++
+ AC_CHECK_HEADERS(unistd.h sys/socket.h winsock.h winsock2.h WS2tcpip.h)
+
+
+--- snes9x/port.h.orig 2005-08-28 16:57:03.000000000 -0400
++++ snes9x/port.h 2005-08-28 17:11:59.000000000 -0400
+@@ -110,6 +110,19 @@
+
+ #include <sys/types.h>
+
++#if defined(HAVE_ENDIAN_H)
++# include <endian.h>
++#endif
++#if defined(HAVE_SYS_ENDIAN_H)
++# include <sys/endian.h>
++#endif
++#if defined(HAVE_MACHINE_ENDIAN_H)
++# include <machine/endian.h>
++#endif
++#if defined(HAVE_SYS_ISA_DEFS_H)
++# include <sys/isa_defs.h>
++#endif
++
+ /* #define PIXEL_FORMAT RGB565 */
+ #define GFX_MULTI_FORMAT
+
+@@ -265,12 +278,27 @@
+ #define SIG_PF void(*)(int)
+ #endif
+
+-#if defined(__i386__) || defined(__i486__) || defined(__i586__) || \
+- defined(__WIN32__) || defined(__alpha__)
+-#define LSB_FIRST
+-#define FAST_LSB_WORD_ACCESS
+-#else
+-#define MSB_FIRST
++#if defined(BYTE_ORDER)
++# if BYTE_ORDER == LITTLE_ENDIAN
++# define LSB_FIRST
++# else
++# define MSB_FIRST
++# endif
++#elif defined(WORDS_LITTLENDIAN)
++# define LSB_FIRST
++#elif defined(WORDS_BIGENDIAN)
++# define MSB_FIRST
++#else
++# if defined(__i386__) || defined(__i486__) || defined(__i586__) || \
++ defined(__WIN32__) || defined(__alpha__) || defined(__x86_64__)
++# define LSB_FIRST
++# else
++# define MSB_FIRST
++# endif
++#endif
++
++#if defined(LSB_FIRST)
++# define FAST_LSB_WORD_ACCESS
+ #endif
+
+ #ifdef __sun