summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-01-03 10:51:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-01-03 10:51:06 +0000
commitb38a453b170cbae4b6210aec608c5ab5395e1ce6 (patch)
treefc46d47a8f8592080be33c2e6e9f46ff7f38638e /games-emulation/stella
parentVersion bumped. (diff)
downloadgentoo-2-b38a453b170cbae4b6210aec608c5ab5395e1ce6.tar.gz
gentoo-2-b38a453b170cbae4b6210aec608c5ab5395e1ce6.tar.bz2
gentoo-2-b38a453b170cbae4b6210aec608c5ab5395e1ce6.zip
version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-emulation/stella')
-rw-r--r--games-emulation/stella/ChangeLog9
-rw-r--r--games-emulation/stella/files/digest-stella-2.33
-rw-r--r--games-emulation/stella/stella-2.3.ebuild48
3 files changed, 58 insertions, 2 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index 68ea90995867..ec2aae426a0a 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.21 2006/08/16 16:40:49 mr_bones_ Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.22 2007/01/03 10:51:06 mr_bones_ Exp $
+
+*stella-2.3 (03 Jan 2007)
+
+ 03 Jan 2007; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.3.ebuild:
+ version bump
16 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org> stella-2.2.ebuild:
avoid pre-stripping files - patch from Tristan Heaven via bug #137834
diff --git a/games-emulation/stella/files/digest-stella-2.3 b/games-emulation/stella/files/digest-stella-2.3
new file mode 100644
index 000000000000..9e63d42f22b2
--- /dev/null
+++ b/games-emulation/stella/files/digest-stella-2.3
@@ -0,0 +1,3 @@
+MD5 9f0a6cf5842a0e03ab2ceb601de10aa3 stella-2.3-src.tar.gz 1307391
+RMD160 6058d12614d8906976021a966b2c410aff814d3e stella-2.3-src.tar.gz 1307391
+SHA256 a1c11304660d2663a6bc70641b3aaccb4d72d85ccd219d02cd09f09ce706deb5 stella-2.3-src.tar.gz 1307391
diff --git a/games-emulation/stella/stella-2.3.ebuild b/games-emulation/stella/stella-2.3.ebuild
new file mode 100644
index 000000000000..e8e4c55473f0
--- /dev/null
+++ b/games-emulation/stella/stella-2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.3.ebuild,v 1.1 2007/01/03 10:51:06 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/strip/d' \
+ -e "/icons/d" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.xpm
+ make_desktop_entry stella Stella stella.xpm
+ prepgamesdirs
+}