summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-02 16:11:11 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-02 16:11:11 +0000
commite00212b3d6c5b7a5d90819c88248551c047b34a2 (patch)
treeaa52a3b1d1edda54cfd7ba2b1a6c81150e332380 /games-emulation/tuxnes/tuxnes-0.75-r1.ebuild
parentalpha stable wrt #175465 (diff)
downloadgentoo-2-e00212b3d6c5b7a5d90819c88248551c047b34a2.tar.gz
gentoo-2-e00212b3d6c5b7a5d90819c88248551c047b34a2.tar.bz2
gentoo-2-e00212b3d6c5b7a5d90819c88248551c047b34a2.zip
remove need for an executable stack
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-emulation/tuxnes/tuxnes-0.75-r1.ebuild')
-rw-r--r--games-emulation/tuxnes/tuxnes-0.75-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/games-emulation/tuxnes/tuxnes-0.75-r1.ebuild b/games-emulation/tuxnes/tuxnes-0.75-r1.ebuild
new file mode 100644
index 000000000000..5ebb6c950c02
--- /dev/null
+++ b/games-emulation/tuxnes/tuxnes-0.75-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/tuxnes/tuxnes-0.75-r1.ebuild,v 1.1 2007/07/02 16:11:11 nyhm Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="emulator for the 8-bit Nintendo Entertainment System"
+HOMEPAGE="http://tuxnes.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="X ggi"
+
+RDEPEND="X? (
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libSM )
+ ggi? ( >=media-libs/libggi-2.0.1 )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/xextproto
+ x11-proto/xproto )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-configure.in.patch \
+ "${FILESDIR}"/${P}-gcc34.patch \
+ "${FILESDIR}"/${P}-include.patch \
+ "${FILESDIR}"/${P}-exec-stack.patch
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --without-w \
+ $(use_with ggi) \
+ $(use_with X x) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon tuxnes.xpm tuxnes2.xpm
+ dodoc AUTHORS BUGS ChangeLog CHANGES NEWS README THANKS
+ prepgamesdirs
+}