summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-29 23:53:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-29 23:53:51 +0000
commit6d7229bbd75587d925df979526f15883de3680c5 (patch)
tree09c5462e3d59582fd1ef598666f5fcaa37832de1 /games-emulation/xmame
parentrewrite the way we apply fedora fixes to avoid the bash bug with ""{} expansion (diff)
downloadgentoo-2-6d7229bbd75587d925df979526f15883de3680c5.tar.gz
gentoo-2-6d7229bbd75587d925df979526f15883de3680c5.tar.bz2
gentoo-2-6d7229bbd75587d925df979526f15883de3680c5.zip
use the -f version of flags instead of -m for gcc-4+ too
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-emulation/xmame')
-rw-r--r--games-emulation/xmame/xmame-0.99-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/games-emulation/xmame/xmame-0.99-r1.ebuild b/games-emulation/xmame/xmame-0.99-r1.ebuild
index 490be374458c..f389cfa38a12 100644
--- a/games-emulation/xmame/xmame-0.99-r1.ebuild
+++ b/games-emulation/xmame/xmame-0.99-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.99-r1.ebuild,v 1.2 2005/08/25 21:58:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.99-r1.ebuild,v 1.3 2005/08/29 23:53:18 vapier Exp $
inherit flag-o-matic toolchain-funcs eutils games
@@ -107,7 +107,7 @@ src_unpack() {
x86|ia64|amd64)
append-flags -Wno-unused -fomit-frame-pointer -fstrict-aliasing -fstrength-reduce
use amd64 || append-flags -ffast-math #54270
- [[ $(gcc-major-version) -eq 3 ]] \
+ [[ $(gcc-major-version) -ge 3 ]] \
&& append-flags -falign-functions=2 -falign-jumps=2 -falign-loops=2 \
|| append-flags -malign-functions=2 -malign-jumps=2 -malign-loops=2
;;