summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-14 06:21:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-14 06:21:07 +0000
commit13091475d3d7669e7fcd131ff22417eca90cdd74 (patch)
treea23b3070ae8ea9a2b2e1304aac88a4e5abcfa3f1 /games-emulation
parentBug #34983, finally a fix from upstream to deal with IPv4-in-IPv6 addresses!. (diff)
downloadgentoo-2-13091475d3d7669e7fcd131ff22417eca90cdd74.tar.gz
gentoo-2-13091475d3d7669e7fcd131ff22417eca90cdd74.tar.bz2
gentoo-2-13091475d3d7669e7fcd131ff22417eca90cdd74.zip
version bump
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest2
-rw-r--r--games-emulation/advancemame/advancemame-0.92.0.ebuild84
-rw-r--r--games-emulation/advancemame/files/0.92.0-pic.patch13
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.92.01
5 files changed, 107 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index 4ea7a1aaa802..e5258dfa1837 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.23 2005/01/20 04:43:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.24 2005/02/14 06:21:07 mr_bones_ Exp $
+
+*advancemame-0.92.0 (14 Feb 2005)
+
+ 14 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.92.0-pic.patch, +advancemame-0.92.0.ebuild:
+ version bump
*advancemame-0.90.0 (19 Jan 2005)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 734fe8ca1b06..77965bacf13d 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,10 +1,12 @@
MD5 b072cefd71538801f10b69973bedcafe ChangeLog 4417
MD5 4c65bbed0b64e385f3884a0a4a2f4db8 advancemame-0.90.0.ebuild 1994
+MD5 4c65bbed0b64e385f3884a0a4a2f4db8 advancemame-0.92.0.ebuild 1994
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
MD5 c47fa3e5e67db3de30c96197dbeb1f3f advancemame-0.88.0.ebuild 1991
MD5 62b15950728d12db8ccf2daa73b490a6 advancemame-0.89.0.ebuild 1990
MD5 2612e9d2dbca377b7052486899a0b004 files/digest-advancemame-0.90.0 72
MD5 893791a430019a7eb1c0eaf15758a93f files/0.90.0-pic.patch 344
+MD5 67836215b1438a2338c7f1ee054b9fb7 files/digest-advancemame-0.92.0 72
MD5 f43f9c3039884207b6e5fc1d91bb46cb files/digest-advancemame-0.88.0 72
MD5 893791a430019a7eb1c0eaf15758a93f files/0.89.0-pic.patch 344
MD5 8aaeef301de9a34d24cfb74973b8ef9b files/digest-advancemame-0.89.0 72
diff --git a/games-emulation/advancemame/advancemame-0.92.0.ebuild b/games-emulation/advancemame/advancemame-0.92.0.ebuild
new file mode 100644
index 000000000000..caa31debbe18
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.92.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.92.0.ebuild,v 1.1 2005/02/14 06:21:07 mr_bones_ Exp $
+
+inherit games eutils
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-pic.patch" #74899
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/0.92.0-pic.patch b/games-emulation/advancemame/files/0.92.0-pic.patch
new file mode 100644
index 000000000000..049befbfac2c
--- /dev/null
+++ b/games-emulation/advancemame/files/0.92.0-pic.patch
@@ -0,0 +1,13 @@
+--- ./advance/blit/blit.c.orig 2004-12-19 01:01:46.039956536 -0500
++++ ./advance/blit/blit.c 2004-12-19 01:01:19.566981040 -0500
+@@ -28,6 +28,10 @@
+ * do so, delete this exception statement from your version.
+ */
+
++#if defined(USE_ASM_INLINE) && defined(__PIC__)
++# undef USE_ASM_INLINE
++#endif
++
+ #include "portable.h"
+
+ #include "blit.h"
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.92.0 b/games-emulation/advancemame/files/digest-advancemame-0.92.0
new file mode 100644
index 000000000000..d5d5e961bd7c
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.92.0
@@ -0,0 +1 @@
+MD5 5a9c65bd6e85f16e5bcdfdfa9c7b47ab advancemame-0.92.0.tar.gz 14359046