summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-14 07:33:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-14 07:33:50 +0000
commit159cea5f91d4544412b902e721a70b52f1edf662 (patch)
tree5b6a3ef69f75b2dffd4871d223e4590a06b794ae /games-emulation
parentEbuild fixes (Manifest recommit) (diff)
downloadgentoo-2-159cea5f91d4544412b902e721a70b52f1edf662.tar.gz
gentoo-2-159cea5f91d4544412b902e721a70b52f1edf662.tar.bz2
gentoo-2-159cea5f91d4544412b902e721a70b52f1edf662.zip
add nojoy.patch to support the -nojoy option even when compiled without joystick support (bug #46210); tidy
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/snes9x/ChangeLog8
-rw-r--r--games-emulation/snes9x/Manifest3
-rw-r--r--games-emulation/snes9x/files/digest-snes9x-1.42-r11
-rw-r--r--games-emulation/snes9x/files/nojoy.patch17
-rw-r--r--games-emulation/snes9x/snes9x-1.42-r1.ebuild73
5 files changed, 101 insertions, 1 deletions
diff --git a/games-emulation/snes9x/ChangeLog b/games-emulation/snes9x/ChangeLog
index 6d978bb9240d..0743451424f1 100644
--- a/games-emulation/snes9x/ChangeLog
+++ b/games-emulation/snes9x/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/snes9x
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.6 2004/04/12 06:56:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/ChangeLog,v 1.7 2004/04/14 07:33:50 mr_bones_ Exp $
+
+*snes9x-1.42-r1 (13 Apr 2004)
+
+ 13 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> snes9x-1.42-r1.ebuild:
+ add nojoy.patch to support the -nojoy option even when compiled without
+ joystick support (bug #46210); tidy
11 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> snes9x-1.39-r1.ebuild,
snes9x-1.41.1.ebuild:
diff --git a/games-emulation/snes9x/Manifest b/games-emulation/snes9x/Manifest
index dd0f5c78d92c..caf9c4870c36 100644
--- a/games-emulation/snes9x/Manifest
+++ b/games-emulation/snes9x/Manifest
@@ -1,9 +1,12 @@
MD5 84d11aceb5a9069d54203c356d7c9c9e ChangeLog 2314
+MD5 0516db5ecb884379043ca324470db2a8 snes9x-1.42-r1.ebuild 1696
MD5 a12af7dbf87cc21b2aa3361625317225 snes9x-1.42.ebuild 1677
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 12216340a66b7cfccf1891ca058d9335 files/nojoy.patch 507
MD5 82847f439abd1f8ae87876515e60ccdf files/1.42-system-zlib.patch 2004
MD5 95a147283e0b09db8ad3307bb3e5b305 files/snes9x-139-r1-BE-sound-fix.diff 550
MD5 5b7c3589393da0616b766b78c69aa16e files/snes9x-139-r1-Makefile-ppc.diff 779
MD5 60e338baf6468da1d0c1fece4884553c files/snes9x-gcc3.diff 979
MD5 82847f439abd1f8ae87876515e60ccdf files/1.41.1-system-zlib.patch 2004
+MD5 29f4c8bf43e00e929c25d85ec4a06b70 files/digest-snes9x-1.42-r1 67
MD5 29f4c8bf43e00e929c25d85ec4a06b70 files/digest-snes9x-1.42 67
diff --git a/games-emulation/snes9x/files/digest-snes9x-1.42-r1 b/games-emulation/snes9x/files/digest-snes9x-1.42-r1
new file mode 100644
index 000000000000..82c4c2809c48
--- /dev/null
+++ b/games-emulation/snes9x/files/digest-snes9x-1.42-r1
@@ -0,0 +1 @@
+MD5 1e8af4c590e35352ddac58d25a468676 snes9x-1.42-src.tar.gz 945282
diff --git a/games-emulation/snes9x/files/nojoy.patch b/games-emulation/snes9x/files/nojoy.patch
new file mode 100644
index 000000000000..3298144f22c0
--- /dev/null
+++ b/games-emulation/snes9x/files/nojoy.patch
@@ -0,0 +1,17 @@
+--- unix/unix.cpp.orig 2004-04-13 03:40:13.000000000 -0700
++++ unix/unix.cpp 2004-04-13 04:00:08.000000000 -0700
+@@ -233,10 +233,12 @@
+
+ void S9xParseArg (char **argv, int &i, int argc)
+ {
+-#ifdef JOYSTICK_SUPPORT
+ if (strcmp (argv [i], "-j") == 0 ||
+- strcasecmp (argv [i], "-nojoy") == 0)
++ strcasecmp (argv [i], "-nojoy") == 0) {
+ Settings.JoystickEnabled = FALSE;
++ return;
++ }
++#ifdef JOYSTICK_SUPPORT
+ else if (strcasecmp (argv [i], "-joydev1") == 0)
+ {
+ if (i + 1 < argc)
diff --git a/games-emulation/snes9x/snes9x-1.42-r1.ebuild b/games-emulation/snes9x/snes9x-1.42-r1.ebuild
new file mode 100644
index 000000000000..697f5e563225
--- /dev/null
+++ b/games-emulation/snes9x/snes9x-1.42-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/snes9x/snes9x-1.42-r1.ebuild,v 1.1 2004/04/14 07:33:50 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Super Nintendo Entertainment System (SNES) emulator"
+HOMEPAGE="http://www.snes9x.com/"
+SRC_URI="http://www.lysator.liu.se/snes9x/${PV}/snes9x-${PV}-src.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 ~ppc"
+IUSE="3dfx opengl X joystick"
+
+RDEPEND="sys-libs/zlib
+ virtual/x11
+ media-libs/libpng
+ opengl? ( virtual/opengl )
+ 3dfx? ( media-libs/glide-v3 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${P}-src"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}/snes9x"
+ epatch "${FILESDIR}/${PV}-system-zlib.patch"
+ epatch "${FILESDIR}/nojoy.patch"
+}
+
+src_compile() {
+ local vidconf=
+ local target=
+ local vid=
+
+ mkdir mybins
+ for vid in 3dfx opengl X ; do
+ use ${vid} || continue
+ cd "${S}/snes9x"
+ case ${vid} in
+ 3dfx)
+ vidconf="--with-glide --without-opengl --without-x"
+ target=gsnes9x;;
+ opengl)
+ vidconf="--with-opengl --without-glide --without-x"
+ target=osnes9x;;
+ X)
+ vidconf="--with-x --without-glide --without-opengl"
+ target=snes9x;;
+ esac
+ # this stuff is ugly but hey the build process sucks ;)
+ egamesconf \
+ --with-screenshot \
+ $(use_with joystick) \
+ ${vidconf} \
+ $(use_with x86 assembler) \
+ || die
+ emake ${target} || die "making ${target}"
+ mv ${target} "${S}/mybins/"
+ cd "${WORKDIR}"
+ rm -rf "${S}/snes9x"
+ src_unpack
+ done
+}
+
+src_install() {
+ dogamesbin mybins/*
+ dodoc faqs.txt readme.txt readme.unix snes9x/*.txt
+ prepgamesdirs
+}