summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-20 19:16:06 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-20 19:16:06 +0000
commit1822b738b640c5d23e06e1ea46618d10acb2a9dd (patch)
treed0d44652cbcdf85c058aa48317f763efea1fba3e /games-emulation
parentReplace patch with a refreshed one in correct unix format. (diff)
downloadgentoo-2-1822b738b640c5d23e06e1ea46618d10acb2a9dd.tar.gz
gentoo-2-1822b738b640c5d23e06e1ea46618d10acb2a9dd.tar.bz2
gentoo-2-1822b738b640c5d23e06e1ea46618d10acb2a9dd.zip
use cleaner method of supporting multilib
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/nestra/nestra-0.66-r1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-emulation/nestra/nestra-0.66-r1.ebuild b/games-emulation/nestra/nestra-0.66-r1.ebuild
index 903d93c5ea60..89b679b5b989 100644
--- a/games-emulation/nestra/nestra-0.66-r1.ebuild
+++ b/games-emulation/nestra/nestra-0.66-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.13 2006/02/11 04:44:27 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestra/nestra-0.66-r1.ebuild,v 1.14 2006/06/20 19:16:06 vapier Exp $
-inherit eutils toolchain-funcs flag-o-matic games
+inherit eutils toolchain-funcs flag-o-matic multilib games
PATCH="${P/-/_}-7.diff"
DESCRIPTION="NES emulation for Linux/x86"
@@ -21,11 +21,6 @@ DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
-pkg_setup() {
- games_pkg_setup
- use amd64 && export ABI=x86
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
@@ -40,6 +35,11 @@ src_unpack() {
|| die "sed failed"
}
+src_compile() {
+ use amd64 && multilib_toolchain_setup x86
+ games_src_compile
+}
+
src_install() {
dogamesbin nestra || die "dogamesbin failed"
dodoc BUGS CHANGES README