summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-11 20:40:17 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-11 20:40:17 +0000
commit204fbd471f51f4ed03e61563dd49c758a65c71d7 (patch)
tree073e16812ddf65a8b258cd8b77dd81f6b0fa089b /games-emulation
parentVersion bump, bug #180969 (diff)
downloadgentoo-2-204fbd471f51f4ed03e61563dd49c758a65c71d7.tar.gz
gentoo-2-204fbd471f51f4ed03e61563dd49c758a65c71d7.tar.bz2
gentoo-2-204fbd471f51f4ed03e61563dd49c758a65c71d7.zip
Version bump, bug #181648
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/openmsx/ChangeLog8
-rw-r--r--games-emulation/openmsx/files/digest-openmsx-0.6.23
-rw-r--r--games-emulation/openmsx/metadata.xml4
-rw-r--r--games-emulation/openmsx/openmsx-0.6.2.ebuild53
4 files changed, 63 insertions, 5 deletions
diff --git a/games-emulation/openmsx/ChangeLog b/games-emulation/openmsx/ChangeLog
index a541c9032a3d..01fdad1badd9 100644
--- a/games-emulation/openmsx/ChangeLog
+++ b/games-emulation/openmsx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/openmsx
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.21 2007/02/21 23:26:59 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/ChangeLog,v 1.22 2007/06/11 20:40:17 nyhm Exp $
+
+*openmsx-0.6.2 (11 Jun 2007)
+
+ 11 Jun 2007; Tristan Heaven <nyhm@gentoo.org> metadata.xml,
+ +openmsx-0.6.2.ebuild:
+ Version bump, bug #181648
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-emulation/openmsx/files/digest-openmsx-0.6.2 b/games-emulation/openmsx/files/digest-openmsx-0.6.2
new file mode 100644
index 000000000000..6d610baa24d3
--- /dev/null
+++ b/games-emulation/openmsx/files/digest-openmsx-0.6.2
@@ -0,0 +1,3 @@
+MD5 282acf2ea7bf67e15a7b8d961c9556a5 openmsx-0.6.2.tar.gz 1934469
+RMD160 b800499248ee43de8007042d4dd0a4523f464833 openmsx-0.6.2.tar.gz 1934469
+SHA256 e7f2c4a6161d3b4e055c42b371e88065d85d6371bc093f9f56c69dfd56261b1f openmsx-0.6.2.tar.gz 1934469
diff --git a/games-emulation/openmsx/metadata.xml b/games-emulation/openmsx/metadata.xml
index 3e83b633049c..d3c2cc926f0b 100644
--- a/games-emulation/openmsx/metadata.xml
+++ b/games-emulation/openmsx/metadata.xml
@@ -2,8 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>games</herd>
-<maintainer>
- <email>chainsaw@gentoo.org</email>
- <name>Tony Vroon</name>
-</maintainer>
</pkgmetadata>
diff --git a/games-emulation/openmsx/openmsx-0.6.2.ebuild b/games-emulation/openmsx/openmsx-0.6.2.ebuild
new file mode 100644
index 000000000000..7d3c9e7cf12d
--- /dev/null
+++ b/games-emulation/openmsx/openmsx-0.6.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/openmsx/openmsx-0.6.2.ebuild,v 1.1 2007/06/11 20:40:17 nyhm Exp $
+
+inherit toolchain-funcs games
+
+DESCRIPTION="MSX emulator that aims for perfection"
+HOMEPAGE="http://openmsx.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="jack"
+
+DEPEND="dev-lang/tcl
+ dev-libs/libxml2
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/glew
+ media-libs/sdl-image
+ virtual/opengl
+ jack? ( media-sound/jack-audio-connection-kit )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i '/LINK_FLAGS+=/s/-s//' build/main.mk || die "sed failed"
+ sed -i \
+ -e "/DISABLED/s:$:$(use jack || echo JACK):" \
+ -e '/SYMLINK/s:true:false:' \
+ build/custom.mk \
+ || die "sed custom.mk failed"
+}
+
+src_compile() {
+ egamesconf || die
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ INSTALL_SHARE_DIR="${GAMES_DATADIR}"/${PN} \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ INSTALL_BINARY_DIR="${D}${GAMES_BINDIR}" \
+ INSTALL_SHARE_DIR="${D}${GAMES_DATADIR}"/${PN} \
+ INSTALL_DOC_DIR="${D}"/usr/share/doc/${PF} \
+ install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ prepgamesdirs
+}