summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-08-21 03:20:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-08-21 03:20:52 +0000
commit405630da2d89c42ee92449f2d52bf783b8b21a6b (patch)
treeac2894ba470715aa3fc8a86f53e1d6f3e83abf0f /games-emulation
parentRemove old version. (diff)
downloadgentoo-2-405630da2d89c42ee92449f2d52bf783b8b21a6b.tar.gz
gentoo-2-405630da2d89c42ee92449f2d52bf783b8b21a6b.tar.bz2
gentoo-2-405630da2d89c42ee92449f2d52bf783b8b21a6b.zip
version bump
(Portage version: 2.1.2.11)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/files/digest-stella-2.43
-rw-r--r--games-emulation/stella/stella-2.4.ebuild48
3 files changed, 57 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index ede59f550f5a..5460f3bcd9de 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.23 2007/01/20 07:00:38 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.24 2007/08/21 03:20:52 mr_bones_ Exp $
+
+*stella-2.4 (21 Aug 2007)
+
+ 21 Aug 2007; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.4.ebuild:
+ version bump
*stella-2.3.5 (20 Jan 2007)
diff --git a/games-emulation/stella/files/digest-stella-2.4 b/games-emulation/stella/files/digest-stella-2.4
new file mode 100644
index 000000000000..65a3bf605565
--- /dev/null
+++ b/games-emulation/stella/files/digest-stella-2.4
@@ -0,0 +1,3 @@
+MD5 538233e42e9cfddf2bc99433e11bb454 stella-2.4-src.tar.gz 1196883
+RMD160 0b206eca4941d1b0db32f9c5103ccdbcd535809c stella-2.4-src.tar.gz 1196883
+SHA256 dffe0915513563981866246a29df7eb4cb0c1e8b6e4a016a478d061c1e2e71e2 stella-2.4-src.tar.gz 1196883
diff --git a/games-emulation/stella/stella-2.4.ebuild b/games-emulation/stella/stella-2.4.ebuild
new file mode 100644
index 000000000000..c4f03d5fd113
--- /dev/null
+++ b/games-emulation/stella/stella-2.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.4.ebuild,v 1.1 2007/08/21 03:20:52 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ media-libs/libpng
+ opengl? ( virtual/opengl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/strip/d' \
+ -e "/icons/d" \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.xpm
+ make_desktop_entry stella Stella stella.xpm
+ prepgamesdirs
+}