summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-05-02 08:55:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-05-02 08:55:04 +0000
commit46d0ac4bfc2819e36a8b838f5b79b8d01dda4e81 (patch)
tree3c3dd00b148e3bf5cd6f778ceafed0ff5d84ed5b /games-emulation
parentUpdate openswan-2.6 p.mask explanation. (diff)
downloadgentoo-2-46d0ac4bfc2819e36a8b838f5b79b8d01dda4e81.tar.gz
gentoo-2-46d0ac4bfc2819e36a8b838f5b79b8d01dda4e81.tar.bz2
gentoo-2-46d0ac4bfc2819e36a8b838f5b79b8d01dda4e81.zip
version bump
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/stella/ChangeLog7
-rw-r--r--games-emulation/stella/stella-2.7.7.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/games-emulation/stella/ChangeLog b/games-emulation/stella/ChangeLog
index bda67c9eccb6..2b86539a1636 100644
--- a/games-emulation/stella/ChangeLog
+++ b/games-emulation/stella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/stella
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.37 2009/04/16 06:22:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/ChangeLog,v 1.38 2009/05/02 08:55:03 mr_bones_ Exp $
+
+*stella-2.7.7 (02 May 2009)
+
+ 02 May 2009; Michael Sterrett <mr_bones_@gentoo.org> +stella-2.7.7.ebuild:
+ version bump
*stella-2.7.6 (16 Apr 2009)
diff --git a/games-emulation/stella/stella-2.7.7.ebuild b/games-emulation/stella/stella-2.7.7.ebuild
new file mode 100644
index 000000000000..f9894dec07c1
--- /dev/null
+++ b/games-emulation/stella/stella-2.7.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/stella/stella-2.7.7.ebuild,v 1.1 2009/05/02 08:55:04 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Stella Atari 2600 VCS Emulator"
+HOMEPAGE="http://stella.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="opengl"
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib
+ opengl? ( virtual/opengl )"
+
+src_prepare() {
+ sed -i \
+ -e '/INSTALL/s/-s //' \
+ -e '/STRIP/d' \
+ -e "/icons/d" \
+ -e '/INSTALL.*DOCDIR/d' \
+ -e '/INSTALL.*\/applications/d' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_configure() {
+ # not an autoconf script
+ ./configure \
+ --prefix="/usr" \
+ --bindir="${GAMES_BINDIR}" \
+ --docdir="/usr/share/doc/${PF}" \
+ --datadir="${GAMES_DATADIR}" \
+ $(use_enable opengl gl) \
+ || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ doicon src/common/stella.png
+ make_desktop_entry stella Stella
+ dohtml -r docs/*
+ dodoc Announce.txt Changes.txt Copyright.txt README-GP2X.txt README-SDL.txt Readme.txt Todo.txt
+ prepgamesdirs
+}