summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-02 16:50:59 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-02 16:50:59 +0000
commit5674761c9f2df8bbb0da8f838da656591ba466a9 (patch)
treef3150d21fe3d83c2b9a65b58e698c67e4c7f2b6f /games-emulation
parentstable x86, bug 183310 (diff)
downloadgentoo-2-5674761c9f2df8bbb0da8f838da656591ba466a9.tar.gz
gentoo-2-5674761c9f2df8bbb0da8f838da656591ba466a9.tar.bz2
gentoo-2-5674761c9f2df8bbb0da8f838da656591ba466a9.zip
update exec stack patch
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gngeo/ChangeLog6
-rw-r--r--games-emulation/gngeo/files/gngeo-0.7-execstacks.patch103
2 files changed, 55 insertions, 54 deletions
diff --git a/games-emulation/gngeo/ChangeLog b/games-emulation/gngeo/ChangeLog
index 6a3682cfa2f6..5ec2b325c6b3 100644
--- a/games-emulation/gngeo/ChangeLog
+++ b/games-emulation/gngeo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/gngeo
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.18 2007/02/07 13:51:06 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.19 2007/07/02 16:50:59 nyhm Exp $
+
+ 02 Jul 2007; Tristan Heaven <nyhm@gentoo.org>
+ files/gngeo-0.7-execstacks.patch:
+ update exec stack patch
07 Feb 2007; Tristan Heaven <nyhm@gentoo.org> gngeo-0.7.ebuild:
Use mirror://berlios
diff --git a/games-emulation/gngeo/files/gngeo-0.7-execstacks.patch b/games-emulation/gngeo/files/gngeo-0.7-execstacks.patch
index 394f86764843..17c576b7d634 100644
--- a/games-emulation/gngeo/files/gngeo-0.7-execstacks.patch
+++ b/games-emulation/gngeo/files/gngeo-0.7-execstacks.patch
@@ -1,28 +1,5 @@
---- src/memcpy.S
-+++ src/memcpy.S
-@@ -495,4 +495,8 @@
-
- Lmemcpy_bsrcul1l4:
- add r1, r1, #1
--b Lmemcpy_bl4
-\ No newline at end of file
-+b Lmemcpy_bl4
-+
-+#ifdef __ELF__
-+.section .note.GNU-stack,"",@progbits
-+#endif
---- ./src/effect/hq3x16.asm
-+++ ./src/effect/hq3x16.asm
-@@ -2520,3 +2520,7 @@
- dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
- dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
-
-+
-+%ifidn __OUTPUT_FORMAT__,elf
-+section .note.GNU-stack noalloc noexec nowrite progbits
-+%endif
---- ./src/effect/2xsaimmx.asm
-+++ ./src/effect/2xsaimmx.asm
+--- src/effect/2xsaimmx.asm
++++ src/effect/2xsaimmx.asm
@@ -2107,3 +2107,7 @@
final1b resb 8
final2a resb 8
@@ -31,8 +8,8 @@
+%ifidn __OUTPUT_FORMAT__,elf
+section .note.GNU-stack noalloc noexec nowrite progbits
+%endif
---- ./src/effect/effect_i386.asm
-+++ ./src/effect/effect_i386.asm
+--- src/effect/effect_i386.asm
++++ src/effect/effect_i386.asm
@@ -88,3 +88,7 @@
emms
@@ -41,8 +18,8 @@
+%ifidn __OUTPUT_FORMAT__,elf
+section .note.GNU-stack noalloc noexec nowrite progbits
+%endif
---- ./src/effect/hq2x16.asm
-+++ ./src/effect/hq2x16.asm
+--- src/effect/hq2x16.asm
++++ src/effect/hq2x16.asm
@@ -1935,3 +1935,7 @@
dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
@@ -51,21 +28,42 @@
+%ifidn __OUTPUT_FORMAT__,elf
+section .note.GNU-stack noalloc noexec nowrite progbits
+%endif
---- ./src/video_i386.asm
-+++ ./src/video_i386.asm
-@@ -86,3 +86,7 @@
-
- popa
- endproc
+--- src/effect/hq3x16.asm
++++ src/effect/hq3x16.asm
+@@ -2520,3 +2520,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
+
+%ifidn __OUTPUT_FORMAT__,elf
+section .note.GNU-stack noalloc noexec nowrite progbits
+%endif
-
- *Note: there are three underscores here on purpose ... otherwise the strip_
- script will produce _OUTPUT_FORMAT__ instead of __OUTPUT_FORMAT__
---- ./src/raze/raze.asm
-+++ ./src/raze/raze.asm
+--- src/memcpy.S
++++ src/memcpy.S
+@@ -495,4 +495,8 @@
+
+ Lmemcpy_bsrcul1l4:
+ add r1, r1, #1
+-b Lmemcpy_bl4
+\ No newline at end of file
++b Lmemcpy_bl4
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
+--- src/raze/Makefile.am
++++ src/raze/Makefile.am
+@@ -20,7 +20,7 @@
+ $(srcdir)/strip_ $< $@
+
+ raze2.asm: raze.asmu raze.incu raze.regu
+- nasm -w+orphan-labels -I $(srcdir)/ -e $< -o $@
++ nasm -w+orphan-labels -f elf -I $(srcdir)/ -e $< -o $@
+
+ # This assembles the file, once it's been pre-processed
+ raze.o: raze2.asm
+--- src/raze/raze.asm
++++ src/raze/raze.asm
@@ -4259,3 +4259,6 @@
;- the end ------------------------------------------------------------------;
@@ -73,8 +71,8 @@
+%ifidn ___OUTPUT_FORMAT__,elf
+section .note.GNU-stack noalloc noexec nowrite progbits
+%endif
---- ./src/screen_i386.asm
-+++ ./src/screen_i386.asm
+--- src/screen_i386.asm
++++ src/screen_i386.asm
@@ -96,3 +96,6 @@
endproc
@@ -95,14 +93,13 @@
}
/****************************************************************************
---- src/raze/Makefile.in.orig 2006-09-02 02:14:11.000000000 -0400
-+++ src/raze/Makefile.in 2006-09-02 02:14:34.000000000 -0400
-@@ -246,7 +246,7 @@
- $(srcdir)/strip_ $< $@
-
- raze2.asm: raze.asmu raze.incu raze.regu
-- nasm -w+orphan-labels -I $(srcdir)/ -e $< -o $@
-+ nasm -w+orphan-labels -f elf -I $(srcdir)/ -e $< -o $@
-
- # This assembles the file, once it's been pre-processed
- raze.o: raze2.asm
+--- src/video_i386.asm
++++ src/video_i386.asm
+@@ -86,3 +86,7 @@
+
+ popa
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif