summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-29 06:19:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-29 06:19:58 +0000
commit5b4cdde14d30adbe84028c394e53fb2e934b3224 (patch)
tree312d58b737f92003422e60e9a8905d9517e09118 /games-emulation
parentthinktux is broken (diff)
downloadgentoo-2-5b4cdde14d30adbe84028c394e53fb2e934b3224.tar.gz
gentoo-2-5b4cdde14d30adbe84028c394e53fb2e934b3224.tar.bz2
gentoo-2-5b4cdde14d30adbe84028c394e53fb2e934b3224.zip
modular X deps from xmess
(Portage version: 2.0.54)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog5
-rw-r--r--games-emulation/xmame/xmame-0.103.ebuild23
2 files changed, 22 insertions, 6 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index fb2dff7a968e..d8564713be4d 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.58 2006/01/25 22:07:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.59 2006/01/29 06:19:58 mr_bones_ Exp $
+
+ 29 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.103.ebuild:
+ modular X deps from xmess
25 Jan 2006; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.103.ebuild:
remove more hard-coded CFLAGS (bug #119953)
diff --git a/games-emulation/xmame/xmame-0.103.ebuild b/games-emulation/xmame/xmame-0.103.ebuild
index c11167cd3726..e6c5ce2a0923 100644
--- a/games-emulation/xmame/xmame-0.103.ebuild
+++ b/games-emulation/xmame/xmame-0.103.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.103.ebuild,v 1.2 2006/01/25 22:07:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.103.ebuild,v 1.3 2006/01/29 06:19:58 mr_bones_ Exp $
inherit flag-o-matic toolchain-funcs eutils games
@@ -18,20 +18,33 @@ IUSE="alsa arts dga esd expat ggi joystick lirc mmx net opengl sdl svga X xinera
RDEPEND="sys-libs/zlib
alsa? ( media-libs/alsa-lib )
arts? ( kde-base/arts )
- dga? ( virtual/x11 )
+ dga? ( || ( ( x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ )
+ virtual/x11
+ )
+ )
esd? ( >=media-sound/esound-0.2.29 )
expat? ( dev-libs/expat )
ggi? ( media-libs/libggi )
lirc? ( app-misc/lirc )
opengl? (
- virtual/x11
virtual/opengl
virtual/glu )
sdl? ( >=media-libs/libsdl-1.2.0 )
svga? ( media-libs/svgalib )
- X? ( virtual/x11 )
- xv? ( virtual/x11 )"
+ xinerama? ( || ( x11-libs/libXinerama virtual/x11 ) )
+ xv? ( || ( x11-libs/libXv virtual/x11 ) )
+ X? ( || ( x11-libs/libXext virtual/x11 ) )"
DEPEND="${RDEPEND}
+ dga? ( || ( ( x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ )
+ virtual/x11
+ )
+ )
+ xinerama? ( || ( x11-proto/xineramaproto virtual/x11 ) )
+ xv? ( || ( x11-proto/videoproto virtual/x11 ) )
x86? ( dev-lang/nasm )"
# Icc sucks. bug #41342
# icc? ( dev-lang/icc )