summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-01-18 01:08:23 +0000
committerTim Harder <radhermit@gentoo.org>2013-01-18 01:08:23 +0000
commit66012a384c635f9ca8b416250d14d98be789d95d (patch)
treef3bd5b62c9c24d2457ecc5036e91282d8c994d92 /games-emulation
parentWorks on alpha, tested on monolith.alpha.dev.gentoo.org. (diff)
downloadgentoo-2-66012a384c635f9ca8b416250d14d98be789d95d.tar.gz
gentoo-2-66012a384c635f9ca8b416250d14d98be789d95d.tar.bz2
gentoo-2-66012a384c635f9ca8b416250d14d98be789d95d.zip
Update live ebuild and call games_pkg_(pre|post)inst functions.
(Portage version: 2.2.0_alpha154/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/vbam/ChangeLog6
-rw-r--r--games-emulation/vbam/vbam-1.8.0.1149.ebuild4
-rw-r--r--games-emulation/vbam/vbam-9999.ebuild30
3 files changed, 34 insertions, 6 deletions
diff --git a/games-emulation/vbam/ChangeLog b/games-emulation/vbam/ChangeLog
index b23ae0fc8366..ef46cf620aaa 100644
--- a/games-emulation/vbam/ChangeLog
+++ b/games-emulation/vbam/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/vbam
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/ChangeLog,v 1.16 2013/01/18 00:59:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/ChangeLog,v 1.17 2013/01/18 01:08:23 radhermit Exp $
+
+ 18 Jan 2013; Tim Harder <radhermit@gentoo.org> vbam-1.8.0.1149.ebuild,
+ vbam-9999.ebuild:
+ Update live ebuild and call games_pkg_(pre|post)inst functions.
*vbam-1.8.0.1149 (18 Jan 2013)
diff --git a/games-emulation/vbam/vbam-1.8.0.1149.ebuild b/games-emulation/vbam/vbam-1.8.0.1149.ebuild
index e02384805b44..7b51cf4201f3 100644
--- a/games-emulation/vbam/vbam-1.8.0.1149.ebuild
+++ b/games-emulation/vbam/vbam-1.8.0.1149.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-1.8.0.1149.ebuild,v 1.1 2013/01/18 00:59:36 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-1.8.0.1149.ebuild,v 1.2 2013/01/18 01:08:23 radhermit Exp $
EAPI=4
WX_GTK_VER="2.8"
@@ -87,12 +87,14 @@ src_install() {
}
pkg_preinst() {
+ games_pkg_preinst
if use gtk || use wxwidgets ; then
gnome2_icon_savelist
fi
}
pkg_postinst() {
+ games_pkg_postinst
if use gtk || use wxwidgets ; then
gnome2_icon_cache_update
fi
diff --git a/games-emulation/vbam/vbam-9999.ebuild b/games-emulation/vbam/vbam-9999.ebuild
index b292a36eee85..0b5461717a86 100644
--- a/games-emulation/vbam/vbam-9999.ebuild
+++ b/games-emulation/vbam/vbam-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-9999.ebuild,v 1.2 2012/09/09 22:10:18 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-9999.ebuild,v 1.3 2013/01/18 01:08:23 radhermit Exp $
EAPI=4
WX_GTK_VER="2.8"
@@ -44,7 +44,8 @@ src_prepare() {
# Fix issue with zlib-1.2.5.1 macros (bug #383179)
sed -i '1i#define OF(x) x' src/common/memgzio.c || die
- sed -i -e "s:\(DESTINATION\) bin:\1 ${GAMES_BINDIR}:" CMakeLists.txt || die
+ sed -i "s:\(DESTINATION\) bin:\1 ${GAMES_BINDIR}:" \
+ CMakeLists.txt src/wx/CMakeLists.txt || die
}
src_configure() {
@@ -60,7 +61,6 @@ src_configure() {
$(cmake-utils_use_enable wxwidgets WX)
$(cmake-utils_use_enable x86 ASM_CORE)
$(cmake-utils_use_enable x86 ASM_SCALERS)
- -DCMAKE_INSTALL_PREFIX="${GAMES_PREFIX}"
-DCMAKE_SKIP_RPATH=ON
-DDATA_INSTALL_DIR=share/games/${PN}
)
@@ -81,3 +81,25 @@ src_install() {
prepgamesdirs
}
+
+pkg_preinst() {
+ games_pkg_preinst
+ if use gtk || use wxwidgets ; then
+ gnome2_icon_savelist
+ fi
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ if use gtk || use wxwidgets ; then
+ gnome2_icon_cache_update
+ fi
+ use gtk && fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ if use gtk || use wxwidgets ; then
+ gnome2_icon_cache_update
+ fi
+ use gtk && fdo-mime_desktop_database_update
+}