summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 07:21:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-25 07:21:11 +0000
commit75a2b3a629b2d9d35c686c1e884d7439fcdc2218 (patch)
tree4ce2c6e954d7ea25b7232cc32b19cb4d1bd9b8f1 /games-emulation
parenthppa KEYWORDS (Manifest recommit) (diff)
downloadgentoo-2-75a2b3a629b2d9d35c686c1e884d7439fcdc2218.tar.gz
gentoo-2-75a2b3a629b2d9d35c686c1e884d7439fcdc2218.tar.bz2
gentoo-2-75a2b3a629b2d9d35c686c1e884d7439fcdc2218.zip
version bump (bug #65192)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/advancemame/ChangeLog8
-rw-r--r--games-emulation/advancemame/Manifest2
-rw-r--r--games-emulation/advancemame/advancemame-0.87.0.ebuild82
-rw-r--r--games-emulation/advancemame/files/digest-advancemame-0.87.01
4 files changed, 92 insertions, 1 deletions
diff --git a/games-emulation/advancemame/ChangeLog b/games-emulation/advancemame/ChangeLog
index d96ea6b51ed3..162b8352ddd5 100644
--- a/games-emulation/advancemame/ChangeLog
+++ b/games-emulation/advancemame/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/advancemame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.18 2004/09/01 02:30:10 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/ChangeLog,v 1.19 2004/09/25 07:21:11 mr_bones_ Exp $
+
+*advancemame-0.87.0 (25 Sep 2004)
+
+ 25 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +advancemame-0.87.0.ebuild:
+ version bump (bug #65192)
*advancemame-0.86.0 (31 Aug 2004)
diff --git a/games-emulation/advancemame/Manifest b/games-emulation/advancemame/Manifest
index 2da0f8f6675b..20f929438e62 100644
--- a/games-emulation/advancemame/Manifest
+++ b/games-emulation/advancemame/Manifest
@@ -1,6 +1,8 @@
MD5 04e2cd1194a80c495f69610b10b96feb ChangeLog 3621
MD5 c7a56ad2d4cb791e613869debc9e18df advancemame-0.86.0.ebuild 1823
+MD5 c7a56ad2d4cb791e613869debc9e18df advancemame-0.87.0.ebuild 1823
MD5 972b8c9f939a33a7074e0819fb55455c metadata.xml 962
MD5 a67ea9d0aba6813bf7099ba0533ba44d advancemame-0.85.0.ebuild 1820
MD5 cfcb101ca859965c03e4c39303d3c481 files/digest-advancemame-0.86.0 72
MD5 0fcd53e6dc55e784545e640310890175 files/digest-advancemame-0.85.0 72
+MD5 2781f763e847a14eef2b5f3520b04231 files/digest-advancemame-0.87.0 72
diff --git a/games-emulation/advancemame/advancemame-0.87.0.ebuild b/games-emulation/advancemame/advancemame-0.87.0.ebuild
new file mode 100644
index 000000000000..4250de9d7232
--- /dev/null
+++ b/games-emulation/advancemame/advancemame-0.87.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/advancemame/advancemame-0.87.0.ebuild,v 1.1 2004/09/25 07:21:11 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNU/Linux port of the MAME emulator with GUI menu"
+HOMEPAGE="http://advancemame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/advancemame/${P}.tar.gz"
+
+LICENSE="GPL-2 xmame"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE="alsa expat fbcon oss sdl slang static svga truetype zlib"
+
+RDEPEND="virtual/libc
+ app-arch/unzip
+ app-arch/zip
+ sdl? ( media-libs/libsdl )
+ slang? ( sys-libs/slang )
+ alsa? ( media-libs/alsa-lib )
+ expat? ( >=dev-libs/expat-1.95.6 )
+ zlib? ( sys-libs/zlib )
+ truetype? ( media-libs/freetype )
+ svga? ( >=media-libs/svgalib-1.9 )"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )
+ virtual/os-headers"
+
+src_unpack() {
+ unpack ${A}
+
+ use x86 && \
+ ln -s $(which nasm) "${T}/${CHOST}-nasm"
+ use sdl && \
+ ln -s $(which sdl-config) "${T}/${CHOST}-sdl-config"
+ use truetype && \
+ ln -s $(which freetype-config) "${T}/${CHOST}-freetype-config"
+}
+
+src_compile() {
+ PATH="${PATH}:${T}"
+ egamesconf \
+ $(use_enable alsa) \
+ $(use_enable expat) \
+ $(use_enable fbcon fb) \
+ $(use_enable oss) \
+ $(use_enable sdl) \
+ $(use_enable slang) \
+ $(use_enable static) \
+ $(use_enable svga svgalib) \
+ $(use_enable truetype freetype) \
+ $(use_enable zlib) \
+ $(use_enable x86 asm) \
+ --with-emu=${PN/advance} \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ local f
+
+ for f in adv* ; do
+ if [ -L "${f}" ] ; then
+ dogamesbin "${f}" || die "dogamesbin failed"
+ fi
+ done
+
+ insinto "${GAMES_DATADIR}/advance"
+ doins support/event.dat
+ keepdir "${GAMES_DATADIR}/advance/"{artwork,diff,image,rom,sample,snap}
+
+ dodoc HISTORY README RELEASE
+ cd obj/doc
+ dodoc *.txt
+ dohtml *.html
+ for f in *.1 ; do
+ newman ${f} ${f/1/6}
+ done
+
+ prepgamesdirs
+}
diff --git a/games-emulation/advancemame/files/digest-advancemame-0.87.0 b/games-emulation/advancemame/files/digest-advancemame-0.87.0
new file mode 100644
index 000000000000..7694dbbed315
--- /dev/null
+++ b/games-emulation/advancemame/files/digest-advancemame-0.87.0
@@ -0,0 +1 @@
+MD5 498d3502e97784e4abc6af6273e50109 advancemame-0.87.0.tar.gz 13069778