summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-05-02 20:09:09 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-05-02 20:09:09 +0000
commit8006ccc0d1b12fc0d0b138bd3472ac24a047bc2f (patch)
tree04b9cf2a93396def5e050dfa2d7308163fa59564 /games-emulation
parentStable on x86 for the sky2 driver. (diff)
downloadgentoo-2-8006ccc0d1b12fc0d0b138bd3472ac24a047bc2f.tar.gz
gentoo-2-8006ccc0d1b12fc0d0b138bd3472ac24a047bc2f.tar.bz2
gentoo-2-8006ccc0d1b12fc0d0b138bd3472ac24a047bc2f.zip
Fix for gcc-4.1
(Portage version: 2.1_pre10-r2)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/pcsx/ChangeLog8
-rw-r--r--games-emulation/pcsx/files/digest-pcsx-1.5-r12
-rw-r--r--games-emulation/pcsx/files/pcsx-1.5-gcc41.patch22
-rw-r--r--games-emulation/pcsx/pcsx-1.5-r1.ebuild7
4 files changed, 34 insertions, 5 deletions
diff --git a/games-emulation/pcsx/ChangeLog b/games-emulation/pcsx/ChangeLog
index 3e1dc92a4d66..81cc1360d62d 100644
--- a/games-emulation/pcsx/ChangeLog
+++ b/games-emulation/pcsx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/pcsx
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/ChangeLog,v 1.7 2005/09/26 17:45:44 wolf31o2 Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/ChangeLog,v 1.8 2006/05/02 20:09:09 tupone Exp $
+
+ 02 May 2006; <Tupone@gentoo.org> +files/pcsx-1.5-gcc41.patch,
+ pcsx-1.5-r1.ebuild:
+ Fix for gcc-4.1
26 Sep 2005; Chris Gianelloni <wolf31o2@gentoo.org> pcsx-1.5-r1.ebuild:
Making games last on inherit line.
diff --git a/games-emulation/pcsx/files/digest-pcsx-1.5-r1 b/games-emulation/pcsx/files/digest-pcsx-1.5-r1
index b3b5dc8f697b..95cebaca47cd 100644
--- a/games-emulation/pcsx/files/digest-pcsx-1.5-r1
+++ b/games-emulation/pcsx/files/digest-pcsx-1.5-r1
@@ -1 +1,3 @@
MD5 591eaf198d3bb3da45a30e4fdffec11c PcsxSrc-1.5.tgz 441651
+RMD160 83e6425cb027c72b5b452b61f6b5a83992c5e065 PcsxSrc-1.5.tgz 441651
+SHA256 49656115a7ade50245e54314052d2a7be814f40c50f609427fe5320eba4435a9 PcsxSrc-1.5.tgz 441651
diff --git a/games-emulation/pcsx/files/pcsx-1.5-gcc41.patch b/games-emulation/pcsx/files/pcsx-1.5-gcc41.patch
new file mode 100644
index 000000000000..eff40e90f98d
--- /dev/null
+++ b/games-emulation/pcsx/files/pcsx-1.5-gcc41.patch
@@ -0,0 +1,22 @@
+--- PsxBios.c.old 2006-05-02 21:22:52.000000000 +0200
++++ PsxBios.c 2006-05-02 21:41:56.000000000 +0200
+@@ -2253,7 +2253,7 @@
+ if (ptr) psxRu32ref(base) = SWAPu32((u32)ptr - (u32)psxM); \
+ else psxRu32ref(base) = 0; \
+ } else { \
+- if (psxRu32(base)) (u8*)ptr = (u8*)(psxM + psxRu32(base)); \
++ if (psxRu32(base)) *(u8**)&ptr = (u8*)(psxM + psxRu32(base)); \
+ else ptr = NULL; \
+ } \
+ base+=4;
+--- R3000A.h.old 2006-05-02 21:44:36.000000000 +0200
++++ R3000A.h 2006-05-02 21:45:07.000000000 +0200
+@@ -135,7 +135,7 @@
+
+ psxRegisters psxRegs;
+
+-#define _i32(x) (long)x
++#define _i32(x) *(long *)&x
+ #define _u32(x) x
+
+ #define _i16(x) (short)x
diff --git a/games-emulation/pcsx/pcsx-1.5-r1.ebuild b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
index ffd8d40fdf6f..1f9dafff2890 100644
--- a/games-emulation/pcsx/pcsx-1.5-r1.ebuild
+++ b/games-emulation/pcsx/pcsx-1.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.7 2005/09/26 17:45:44 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/pcsx/pcsx-1.5-r1.ebuild,v 1.8 2006/05/02 20:09:08 tupone Exp $
inherit eutils games
@@ -34,7 +34,8 @@ src_unpack() {
edos2unix `find -regex '.*\.[ch]'`
- epatch ${FILESDIR}/${PV}-gentoo.patch
+ epatch ${FILESDIR}/${PV}-gentoo.patch \
+ "${FILESDIR}/${P}"-gcc41.patch
sed -i \
-e "s:Plugin/:${GAMES_LIBDIR}/psemu/plugins/:" \
-e "s:Bios/:${GAMES_LIBDIR}/psemu/bios/:" \