summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-30 16:43:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-30 16:43:44 +0000
commit892dbe69992e86d260edac77fb42f984db9b046c (patch)
treec87313a19cc69674a5ce28c39fca2b8cc3ba3d97 /games-emulation
parentplace sources at my devspace as upstream tarball checksum changes (diff)
downloadgentoo-2-892dbe69992e86d260edac77fb42f984db9b046c.tar.gz
gentoo-2-892dbe69992e86d260edac77fb42f984db9b046c.tar.bz2
gentoo-2-892dbe69992e86d260edac77fb42f984db9b046c.zip
EAPI=5; fix compile with newer zlib (bug #494168)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/gngb/ChangeLog5
-rw-r--r--games-emulation/gngb/gngb-20060309.ebuild16
2 files changed, 14 insertions, 7 deletions
diff --git a/games-emulation/gngb/ChangeLog b/games-emulation/gngb/ChangeLog
index 2f3f02cd6dcc..8961f9cbc2d4 100644
--- a/games-emulation/gngb/ChangeLog
+++ b/games-emulation/gngb/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/gngb
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/ChangeLog,v 1.16 2014/05/15 16:36:48 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/ChangeLog,v 1.17 2014/07/30 16:43:44 mr_bones_ Exp $
+
+ 30 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org> gngb-20060309.ebuild:
+ EAPI=5; fix compile with newer zlib (bug #494168)
15 May 2014; Ulrich Müller <ulm@gentoo.org> gngb-20060309.ebuild:
Fix USE dependency on media-libs/libsdl, "audio" USE flag was renamed to
diff --git a/games-emulation/gngb/gngb-20060309.ebuild b/games-emulation/gngb/gngb-20060309.ebuild
index b31bd89b15c5..2e2467cb9d07 100644
--- a/games-emulation/gngb/gngb-20060309.ebuild
+++ b/games-emulation/gngb/gngb-20060309.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/gngb-20060309.ebuild,v 1.9 2014/05/15 16:36:48 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngb/gngb-20060309.ebuild,v 1.10 2014/07/30 16:43:44 mr_bones_ Exp $
-EAPI=2
-inherit games
+EAPI=5
+inherit autotools eutils games
DESCRIPTION="Gameboy / Gameboy Color emulator"
HOMEPAGE="http://m.peponas.free.fr/gngb/"
@@ -19,14 +19,18 @@ DEPEND="media-libs/libsdl[sound,joystick,video]
app-arch/bzip2
opengl? ( virtual/opengl )"
-PATCHES=( "${FILESDIR}"/${P}-ovflfix.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ovflfix.patch
+ sed -i -e '70i#define OF(x) x' src/unzip.h || die
+ eautoreconf
+}
src_configure() {
- egamesconf $(use_with opengl gl)
+ egamesconf $(use_enable opengl gl)
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ emake DESTDIR="${D}" install
dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
}