summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-02-09 10:21:03 +0000
committerTim Harder <radhermit@gentoo.org>2011-02-09 10:21:03 +0000
commit9771ee2c29db84e1d1ec92eab010d70ce1e566c8 (patch)
tree52c42f7a204022c4e460d3187e708b5d813f91fc /games-emulation
parentBump for #354217 (diff)
downloadgentoo-2-9771ee2c29db84e1d1ec92eab010d70ce1e566c8.tar.gz
gentoo-2-9771ee2c29db84e1d1ec92eab010d70ce1e566c8.tar.bz2
gentoo-2-9771ee2c29db84e1d1ec92eab010d70ce1e566c8.zip
Initial import (bug #254480). Ebuild by me.
(Portage version: 2.2.0_alpha22/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/vbam/ChangeLog11
-rw-r--r--games-emulation/vbam/files/vbam-1.8.0_p20110206-cflags.patch11
-rw-r--r--games-emulation/vbam/files/vbam-1.8.0_p20110206-disable-asm.patch20
-rw-r--r--games-emulation/vbam/metadata.xml9
-rw-r--r--games-emulation/vbam/vbam-1.8.0_p20110206.ebuild56
5 files changed, 107 insertions, 0 deletions
diff --git a/games-emulation/vbam/ChangeLog b/games-emulation/vbam/ChangeLog
new file mode 100644
index 000000000000..7b8a07527706
--- /dev/null
+++ b/games-emulation/vbam/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-emulation/vbam
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/ChangeLog,v 1.1 2011/02/09 10:21:03 radhermit Exp $
+
+*vbam-1.8.0_p20110206 (09 Feb 2011)
+
+ 09 Feb 2011; Tim Harder <radhermit@gentoo.org> +vbam-1.8.0_p20110206.ebuild,
+ +files/vbam-1.8.0_p20110206-cflags.patch,
+ +files/vbam-1.8.0_p20110206-disable-asm.patch, +metadata.xml:
+ Initial import (bug #254480). Ebuild by me.
+
diff --git a/games-emulation/vbam/files/vbam-1.8.0_p20110206-cflags.patch b/games-emulation/vbam/files/vbam-1.8.0_p20110206-cflags.patch
new file mode 100644
index 000000000000..ef303957f5a4
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-1.8.0_p20110206-cflags.patch
@@ -0,0 +1,11 @@
+--- vbam-1.8.0_p20110206/CMakeLists.txt.orig
++++ vbam-1.8.0_p20110206/CMakeLists.txt
+@@ -116,8 +116,6 @@
+ ELSE ( WIN32 )
+ SET( CMAKE_ASM_FLAGS "-I$(CMAKE_SOURCE_DIR)/src/filters/hq/asm/ -O1 -DELF -w-orphan-labels")
+ ENDIF ( WIN32 )
+-SET( CMAKE_C_FLAGS "-O3 -Wall")
+-SET( CMAKE_CXX_FLAGS "-O3 -Wall")
+
+ # Source files definition
+ SET(SRC_FEX
diff --git a/games-emulation/vbam/files/vbam-1.8.0_p20110206-disable-asm.patch b/games-emulation/vbam/files/vbam-1.8.0_p20110206-disable-asm.patch
new file mode 100644
index 000000000000..2007dd7e1434
--- /dev/null
+++ b/games-emulation/vbam/files/vbam-1.8.0_p20110206-disable-asm.patch
@@ -0,0 +1,20 @@
+--- vbam-1.8.0_p20110206/CMakeLists.txt.orig
++++ vbam-1.8.0_p20110206/CMakeLists.txt
+@@ -1,5 +1,5 @@
+ # The project's name is VBA-M it uses assembly, C and C++ code
+-PROJECT(VBA-M ASM C CXX)
++PROJECT(VBA-M C CXX)
+
+ cmake_minimum_required( VERSION 2.4.6 )
+ if( COMMAND cmake_policy )
+@@ -10,8 +10,8 @@
+
+ # Include the definition of the ASM compiler. It will look for nasm
+ # This is probably not needed if CMake 2.6 or above is used
+-INCLUDE(CMakeScripts/CMakeDetermineASMCompiler.cmake)
+-INCLUDE(CMakeScripts/CMakeASMInformation.cmake)
++#INCLUDE(CMakeScripts/CMakeDetermineASMCompiler.cmake)
++#INCLUDE(CMakeScripts/CMakeASMInformation.cmake)
+
+ # Also need to look for SFML
+ INCLUDE(CMakeScripts/FindSFML.cmake)
diff --git a/games-emulation/vbam/metadata.xml b/games-emulation/vbam/metadata.xml
new file mode 100644
index 000000000000..8ad81e6612d1
--- /dev/null
+++ b/games-emulation/vbam/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version = '1.0' encoding = 'UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>radhermit@gentoo.org</email>
+ <name>Tim Harder</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-emulation/vbam/vbam-1.8.0_p20110206.ebuild b/games-emulation/vbam/vbam-1.8.0_p20110206.ebuild
new file mode 100644
index 000000000000..0160ddf3992d
--- /dev/null
+++ b/games-emulation/vbam/vbam-1.8.0_p20110206.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/vbam/vbam-1.8.0_p20110206.ebuild,v 1.1 2011/02/09 10:21:03 radhermit Exp $
+
+EAPI=2
+
+inherit confutils games cmake-utils eutils
+
+DESCRIPTION="Game Boy, GBC, and GBA emulator forked from VisualBoyAdvance"
+HOMEPAGE="http://vba-m.ngemu.com"
+SRC_URI="http://dev.gentoo.org/~radhermit/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk lirc +sdl"
+
+RDEPEND="media-libs/libpng
+ media-libs/libsdl[joystick]
+ media-libs/libsfml
+ sys-libs/zlib
+ virtual/opengl
+ gtk? ( >=dev-cpp/libglademm-2.4.0
+ >=dev-cpp/glibmm-2.4.0
+ >=dev-cpp/gtkmm-2.4.0
+ >=dev-cpp/gtkglextmm-1.2.0 )
+ lirc? ( app-misc/lirc )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ confutils_require_any sdl gtk
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-cflags.patch \
+ "${FILESDIR}"/${P}-disable-asm.patch
+}
+
+src_configure() {
+ mycmakeargs="$(cmake-utils_use_no sdl SDL)
+ $(cmake-utils_use_no gtk GTK)
+ $(cmake-utils_use_with lirc LIRC)
+ -DCMAKE_INSTALL_PREFIX=${GAMES_PREFIX}"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use sdl ; then
+ dodoc doc/ReadMe.SDL.txt
+ doman debian/vbam.1
+ fi
+ prepgamesdirs
+}